0

Using the Drupal Solr admin UI I indexed all queued content. However, even if everything is indexed and searchable, it indicates, as seen below, that only 2% has been indexed!

Indexed 31084 Items (934.03 MB on disk) Remaining 30597 items (2% has been sent to the server) Schema drupal-4.1-solr-3.x

The problem is that when I want to index the remaining, it starts from zero. Why is that? Is it a bug?

0

Indexing is done during cron runs. When you've set up indexing, don't ask for it to be indexed again, unless you want it to start from scratch.

If you want to increase the percentage, and don't want to wait for the next scheduled cron run, run cron manually by navigating to Home » Administration » Configuration » System » Cron and press Run cron.

If you want to automate this, set up an external cron and trigger it every 10 minutes until indexing is done.

There is no setting to index everything instantly. If that is what you want to do, the answer is that this is not possible. You have to be patient. The reason there is no such setting is because that would put a too heavy load on your system. The system is designed to work the way it works for a reason.

3
  • Ok I agree with that, but, what if I really want to index all remaining at once? I bulk upload 30.000 records, I cannot wait them to be index as per 50, or 100 or what ever the cron setting is set. And what is the meaning of index all remaining button if not to index only the remaining? Logically, judging from the button name, it should only index the nodes left in the queue. Isn't that right? Is there a way to uplift the percentage programmatically?
    – Maggie
    Jun 13 '14 at 6:35
  • Another thing I cannot understand is that if what you describe is correct, then when I click the Index all queue content button and everything is indexed from the beginning, and then the cron runs as it should be, the percentage should change. This however isn't true. The percentage remains the same. If I do not index all at once and let the cron do its job, the percentage changes, but I will have to ewait forever to index all...
    – Maggie
    Jun 13 '14 at 6:40
  • @Margarita, there is no setting to index everything instantly. What you want to do is not possible. You have to be patient. The reason there is no such setting is because that would put a too heavy load on your system. The system is designed to work the way it works for a reason. Jun 13 '14 at 7:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.