0

Drupal compress (with gzip) on the fly all files attached to pages during sending them to browser.
It takes too much time especially with PDF.

How to turn it off?

Drupal 6

edit:
Drupal do not compress pages on its own (option turned off), but apache does (output coming from php). And I want to stay it that way with exception of application/pdf (also output of php)

Is it possible?

edit2:
I couldn't change apache gzipping settings in .htaccess, but I was planning changing hosting. I've speeded it up a little and problem is gone now.

2
  • 1
    Note that the html of the page is compressed if you select compression on admin/settings/performance, but I don't think that's what you're saying.
    – rfay
    Sep 22 '11 at 13:29
  • May be a better question for serverfault.com
    – mpdonadio
    Sep 22 '11 at 15:25
5

The question here is one of Apache configuration, rather than Drupal.

I'd suggest checking out the Apache mod_deflate documentation, which contains sample configurations to disable/enable compression in a variety of circumstances.

1
  • You've pointed me in right direction but I could't change this settings on my hosting even in .httaccess. But I've changed hosting ;) Sep 24 '11 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.