2

I am looking to create the ability to have my slider images link to link specified in my field_link. I have tried to put the node [field_link], but it is reading as plain text. I have tried a few suggestions, but I must not be doing them right.

Below you will find the current configuration I am using.

This is how I have set up my Slideshow View: This is how I have set up my Slideshow View

This is how I have set up my Image Field: enter image description here

This is how I have set up my Link Field: enter image description here

0

I do this the same way you are doing it. Try putting (rearrange order) the field_link before/above the field_image in your view fields list. Views reads through them one at a time.. and as you have it, field_link isn't yet available when it's processing the field_image. does that make sense?

|improve this answer|||||
  • Do you leave link path blank? – user32180 Jun 19 '14 at 1:21
  • no, you have everything in the right place, using the correct tokens. The only reason the link isn't available it seems, it because you have Field:link after Field:Image. If you click 'Rewrite the output of this field' you can see a list of "available" tokens for each field as you move down you list. You may find it useful to see how Views handles this – Joe Mewes Jun 19 '14 at 12:00
  • I eventually found out that the replacement pattern I was using was slightly incorrect. Thanks so much for all of your help. – user32180 Jun 19 '14 at 16:14
0

I have always had to modify the view template for the specific display to wrap everything in a link properly. The issue is compounded even more when using Picture for responsive image variations.

The custom template changes aren't extensive, but I've not found a re-usable or GUI based method to do this with sliders.

|improve this answer|||||
  • 2
    Ok would you mind expanding on the template changes you have made? – user32180 Jun 17 '14 at 13:32
-1

How do you get fields: ? I only have content and feeds etc. not fields.

I have a field collection with three fields: 1: field_slideshow_link 2: field_slideshow_image 3: field_slideshow_title

I want to link the image to the link provided in 1.

so I want to rewrite the output, "Output this field as a link" setting should be [field_slideshow_link] How do I do that in a collection?

|improve this answer|||||
  • this is not the answer, create the new question for this... – mixerowsky May 30 '15 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.