0

After following instructions given here: https://drupal.org/project/ocupload#install-swfupload I got an upload button. Further it is possible to upload images within the backend. After saving the page there are visible as well.

But if I call the page in frontend there's text only.

Is there a way to solve my problem for free?

ubuntu 12.04, drupal 7.28, ckeditor 4.4.1, firefox and chromium newest release

1

This problem is probably related to the text format used when the page containing the image is rendered.

If the text format used is "Filtered HTML", you should try to change the format for the node to "Full HTML". If this change makes the missing images re-appear, the problem is the text format.

If only trusted users are allowed to insert images in nodes, you can fix the problem by changing the default text format from "Filtered HTML" to "Full HTML". However, it is not recommended to allow untrusted users use this text format, as it allows XSS attacks.

For a secure configuration where untrusted users can insert images, you need to use a better filter module that the default "Filtered HTML". You can do this by installing the WYSIWYG Filter module as is decribed here.

0

I use elfinder with CKEditor, and it provides a great image upload interface. It also allows you to manage files at the content overview, which is helpful.

2
  • First I installed elFinder under '/sites/all/libraries/' and the elFinder module as well. After installing elFinder I was requested to install 'elfinder_bueditor' and 'elfinder_ffsel'. link. The main problem deals with the config.js I guess: // Configure CKEditor to use the elFinder file manager (new line) config.filebrowserBrowsUrl = '/var/www/sites/all/libraries/elfinder/elfinder.php.html'; How do I find the correct path?
    – bolshii
    Jun 18 '14 at 9:37
  • Got it! Solution found here: link >> I had exactly the same problem, and this is the solution: install ck editor (and follow the readme) install IMCE then go to site configuration > ck editor: - assign a role to the default and advanced profiles (click on "basic settings", and check "Roles allowed to use this profile") - then click on "File Browser settings", and check IMCE Done! << Feel free to tell if there's another way.
    – bolshii
    Jun 18 '14 at 13:56
0

If your image is showing up in your backend, and you are using Filtered HTML, then all you need to do is allow the tag in your Filtered HTML format. Just navigate to

/admin/config/content/formats/filtered_html

and add that tag to the "Limit allowed HTML tags" at the bottom of the form.

2
  • This is not good advice. There is a reason <img> is omitted from the list of permitted tags for "Filtered HTML". If you allow the <img> tag to be rendered in "Filtered HTML" text (Drupal's default text format for untrusted users) you're making your site wide open to XSS attacks. Jun 17 '14 at 18:34
  • It depends if you're using Filtered HTML for any anonymous users and literal untrusted users. I utilize Filtered for my logged in site maintainers with a very limited tag list. I agree, don't enable <img> on anonymous fields. Jun 17 '14 at 18:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.