2

I've just configured my website to work with secure pages and everything seems to be working fine except for the ability to install a new module. Whenever I try, I get this error:

An AJAX HTTP request terminated abnormally. Debugging information follows. Path: https://www.mysite.com/authorize.php?batch=1&id=329&op=do[1] StatusText: ResponseText: ReadyState: 4

It also offers an error page that says this:

Notice: Undefined index: log in update_authorize_install_batch_finished() (line 250 of /home1/me/public_html/mysite.com/modules/update/update.authorize.inc). Warning: Invalid argument supplied for foreach() in update_authorize_install_batch_finished() (line 250 of /home1/me/public_html/mysite.com/modules/update/update.authorize.inc). Notice: Undefined index: log in update_authorize_install_batch_finished() (line 291 of /home1/me/public_html/mysite.com/modules/update/update.authorize.inc). Notice: Undefined index: tasks in update_authorize_install_batch_finished() (line 292 of /home1/me/public_html/mysite.com/modules/update/update.authorize.inc). Installation failed! See the log below for more information.

All I can find on secure pages and AJAX is to add */ajax/* to the "ignore pages" field. I've done that but I'm still having the same issue. Has anyone else figured this out? I feel like it should be pretty standard stuff!

  • Try adding batch to the ignore pages – Clive Jun 17 '14 at 21:22
  • Can you still enable modules using Drush? Are you using the 'Module Filter' module? If so try disabling that? – iain maitland Jun 17 '14 at 21:25
  • I tried looking into drush but I don't understand github and how to get the most recent version. I think I got the master branch, however I ended up getting some errors when I used that (which I don't think are related). However that could just be because I don't know what I'm doing. I don't think the error is related to the actual module install because I can do it manually and it works. I also tried adding batch to the ignore pages and disabling module filter, neither idea worked. – user32223 Jun 17 '14 at 23:28
0

I got this same error, but the cause was unrelated to secure pages, so it may not apply to your case. Mine resulted from upgrading to Drupal 7.3 and having uncommented the two lines in the .htaccess file "To redirect all users to access the site WITHOUT the 'www.' prefix." When I commented those two lines, my module installer started working again. So if you have those two lines in .htaccess uncommented, try commenting them out and see if that makes a difference.

  • Thanks so much! That definitely solved my problem. I'm finally able to update my modules and work in the backend! :) – user32223 Aug 24 '14 at 2:09
0

I had the same problem installing modules, would receive the same error mentioned in OP.

After reading the first answer posted above, I tried that but it did not work for me. However, that made me think my other edits to .htaccess (redirect to HTTPS for all links) may be the cause. I restored the original .htaccess that is installed with drupal and I was able to get past the error I was having.

I then restored the .htaccess file for the HTTPS redirects and things seem to be working fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.