1

I'm able to create coupons with no errors. When I enter coupon code into the field and click on the submit button I get the following error.

An AJAX HTTP error occurred.
HTTP Result Code: 500
Debugging information follows.
Path: /system/ajax
StatusText: Service unavailable (with message)
ResponseText:

Drupal version 7.28

Commerce Coupon Percentage 7.x-1.0-beta7

dblog messages

// first error
Rules Warning:
  Unable to get a data value.
Error: 
  Unable to get the data property code as the parent data structure is not set.
// second error
Rules Warning:
  Unable to evaluate condition commerce_coupon_discount_coupon_codes_exist_on_order.
// second error
PHP Error:
  EntityMetadataWrapperException:
  Unable to get the data property coupon_id as the parent data structure is not set.
  in EntityStructureWrapper->getPropertyValue()(line 438 of /homepages/
  36/d385915579/htdocs/bbp/sites/all/modules/entity/includes/entity.wrapper.inc).
  • That means a fatal error happen when processing the AJAX petition. Check the dblog entries (/admin/reports/dblog, make sure db log core module is enabled). Also check your PHP log errors (log path depends on your system setup) – sanzante Jun 19 '14 at 19:32
  • I edited the post to include dblog messages. – dimmech Jun 19 '14 at 19:50
0

This seems an error in Commerce Coupon Percentage module. Your problem comes from the EntityMetadataWrapperException: when processing the AJAx petition something goes wrong and an Exception is throw. This is fatal, so Apache ends the petition with the status 500.

I think this a bug in the module code, so you may go the issue queue for this module and create a new bug report with your problem.

By the way, the Commerce Coupon Percentage is only comptabible with Commerce Coupon 1.x, check your are using a 1.x release.

  • You were right to suggest I look at the version of Commerce Coupon. After some considerable effort I was able to reinstall everything which cleared up the EntityMetadataWrapperException: Error for coupon_id however I now get one for currency_code and I still have the ajax error which may or may not be related. I'm going to ask a separate question to deal with the remaining errors and how to find out their causes. Thank you @tunic! – dimmech Jun 27 '14 at 18:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.