2

There is one my online website in Drupal. I did a Setup on Localhost for Testing Purpose. But unable to get it working correctly.

  • Using WAMP
  • Used Migrate tool.

I tried:

  1. Deleted .htaccess file.
  2. Base URL set.
  3. Tried to access all possible Admin URL, sitename.com/admin .
  4. Clean URL disabled on localhost.

Problem:

  1. All pages working fine that means FRONT END IS FINE. But while accessing BACKEND for user or admin is just not working. It says PAGE NOT FOUND.
  2. When I use admin URL as following: sitename.com/?q=admin = It redirects to https://localhost/sitename/?q=toboggan/denied&destination=admin

I'm not sure how it is adding https. Page says: unable to connect If I use sitename.com/admin it says: "Page not found".

Please suggest the solution.

  • Are you using LoginToboggan module ?I think that's because of LoginToboggan module. – Krishna Mohan Jun 20 '14 at 14:22
  • I disabled the same module from database but it dint work. any other suggestion please? – Sameer Jun 20 '14 at 15:21
1

This issue might be a variation of the question about "drupal /?q=user is working but /user not working". So verify if you can use an URL containing ?q=user or ?q=admin. If that gets you going, then probably tuning RewriteBase in your .htaccess (as described in the accepted answer of that question) should help.

It might be worth trying to further enhance your .htaccess file, by adding a line after that existing RewriteBase, which looks like so:

RewriteRule . index.php [L]

For more details on the above line, refer to the (accepted) answer in this question on StackOverflow.

Another option for debugging is to retry using another browser. If via that browser you are able to login, then it's probably a cookie problem (in your original browser).

If http redirects to https you might have a module that does this or it might be a rule in .htaccess see if you can comment out the rule in htaccess or disable any relevant module with drush dis MODULENAME.

If none of these suggestions help, then re-edit your question by adding more details about which modifications to your '.htaccess file, httpd.conf, etc' you already tried (and didn't work).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.