7

I have created a custom region called latest. And when I am assigning some block to that region from admin, while saving it returns this error

Region for Main page content block field is required.

What might be the reason?

  • The exact message provided "Region for Main page content block field is required" results when trying to assign blocks in some themes (bootstrap). The cause is that the 'Main page content' block has not been assigned to any region. Assigning it to a region resolves the problem. – Interlated Jun 6 '17 at 20:03
3

I did a search for the error message "region for main page content block field is required" which produced theses results:

It appears that you need to assign content/block to the "Main page" region as it's currently empty.

5

This post helped me get closer, but I thought I would provide a more concise answer for those following the same path.

If you are looking to remove all blocks from Drupal 7, like you would want to do if you were placing blocks by using Context, you want to make sure that core's "Main page content" is the last block removed.

Steps:

  1. Select "- None -" for all other blocks, then click Save.
  2. Then change the "Main page content" block's region to "- Select -" and click Save.
  • in drupal 7.31, i'm able to just select "select" as the option for main content to make it not show up, but the only problem is if you activate another block and try to save it will throw that error. at which point u just select "select" again for main content to make it disappear. it seems like its a bug, but its not. just gotta set the main block setting last. – Patoshi パトシ Oct 24 '14 at 20:17
3

To get rid from this error, just assign a "main page content" block to the content region in administrator >> structure >> blocks; then press the "Save block" button at bottom.

2

Looks like the region content is compulsory in the theme-name.info file. I added that and everything got solved. Just had to add the following

regions[content] = Content
1

You could use the Context module for assignment of blocks, make sure to remove the Main content block of the blocks overview page as the last one.

-1

Just enable the "Main Content Page" block in Structure>Blocks then save. That will save the problem.

Not the answer you're looking for? Browse other questions tagged or ask your own question.