0

I'm using the paid theme md-alpine and I added a content type called webinars, and a node template for webinars node--webinars.tpl.php

The only thing I put in the page is and I only get an HTML page with no CSS. Am I supposed to add a call to the node--webinars.tpl.php page somewhere?

EDIT: I changed dpm to print_r and the rest of the theme printed. Put it back to dpm and it doesn't load.

enter image description here

This is the raw output of the page:

    <div id="navigation" class="navbar navbar-default navbar-fixed-top" role="navigation">
    <div class="navbar-inner">
        <div class="navbar-header">
            <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-collapse">
                <span class="sr-only">Toggle navigation</span>
                <i class="icon fontello icon-menu icon-2x"></i>
            </button>
            <a id="brand" class="navbar-brand" href="http://lcl.alpine.test"> <img src="http://lcl.alpine.test/sites/all/themes/md_alpine/img/logo.png" alt=""> </a>
        </div>
        <div class="navbar-collapse collapse">
            <ul class="menu nav navbar-nav navbar-right"><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#home">Home</a></li><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#about">About</a></li><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#portfolio">Gallery</a></li><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#team">Staff</a></li><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#client">Testimonials</a></li><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#pricing">Donations</a></li><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#blog">Blog</a></li><li><a class="int-collapse-menu" href="http://lcl.alpine.test/#contact">Contact</a></li><li class="last leaf"><a href="/members" title="Member&#039;s Area">Members</a></li>
</ul>        </div>
    </div>
</div><section class="section-content blog-content">
    <div class="container">
        <!-- Section title -->
                <div class="section-title text-center">
            <div>

                <span class="line big"></span>
                <span>Posted by <a href="http://lcl.alpine.test/user/1">admin</a></span>
                <span class="line big"></span>

            </div>
            <h1>Test</h1>
            <div>
                <span class="line"></span>
                <span><i class="fontello icon-calendar"></i>21 June 2014</span>
                <span class="line"></span>
            </div>
            <p class="lead">
                            </p>
        </div>
                <!-- Section title -->
        <div class="row">

                    <div class="col-md-9">
                                                <div class="tabs"><h2 class="element-invisible">Primary tabs</h2><ul class="tabs primary"><li class="active"><a href="/webinars/test" class="active">View<span class="element-invisible">(active tab)</span></a></li>
<li><a href="/node/39/edit">Edit</a></li>
</ul></div>
  • " I changed dpm to print_r and the rest of the theme printed" - where, and why? - neither of these functions have anything to do with the standard output and shouldn't affect it? can you post your node--webinars.tpl.php if it isn't too big. – Geoff Jun 22 '14 at 0:12
  • 1
    node--webinars.tpl.php - it's called automatically, looks like you broke something, so page.tpl.php or html.tpl.php doesn't fired. Need to more investigate, did you add code to template.php? – Nikit Jun 22 '14 at 0:29
0

Devel got disabled somehow breaking the page when calling dpm. Re-enabling fixed all.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.