0

i have a certain problem regarding a content type and a "supervisor" role for it.

For the content type (which unfortunately did not create it myself but found it on an ongoing project), i have created a certain role (lets say "Supervisor" ) which shall give access to each user to "editing own content". Since all the content in this content type are created by the admin, for test purposes, i changed the author of a node from "Admin" to "user_1", and then later loged-in as "user_1" to edit the node, but no luck.

I tried several other alternatives, such as "content access" module, "create new content" permission, flexi-acces module, but nothing worked.

Whenever i try ../node/xxx/edit, it displays the node and not the edit screen.

Any ideas why this happens?

** i gave the "edit all content" permissions to the role, and the user could edit all the profiles (obviously) - i just wanted to check if everything works ok with the roles **

2

Make sure the "user_1" has a role as "Supervisor".And also check "content type: Edit own content" permission in people->permissions has assigned to "Supervisor" Role.Finally clear the performance.

  • Unfortunately that was not that obvious. The problem was somewhere else. Check my answer below. and thanks anyway for your answer! :-) – neu _ sturz _ ende Jun 24 '14 at 13:55
1

Step by step how you can solve this :-

Lets say i have content type 'demo'.

=> Now Admin creates an node of type demo and changed the author name to (lets say 'supervisor' that have role 'supervisor')

=> Now give permissions to 'supervisor' role to 'View published content' and 'demo: Edit own content' as shown in below screenshots

enter image description here

and then save permissions

=> login as user 'supervisor' with role 'supervisor'.now 'supervisor' can edit node that have content type 'demo'.

  • Thanks for the detailed answer, i tried everything before asking, except the "view published content" (which did not also worked), but the problem was somewhere else and not that obvious at all (in my opinion). Check my answer underneath! – neu _ sturz _ ende Jun 24 '14 at 13:54
0

I found where the problem was and i think it is a little bit tricky.

I use different theme as user and different theme as admin. Therefore the "edit" procedure takes place under the "admin theme" (i do not know if i expressed that correctly, i hope you get what i mean). So, if the desired role does not have the property "View the administration theme", no matter how correctly are the permissions set, you do not have access to the "edit" page. Weird in my opinion. Anyway, i hope this will help someone in the future!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.