0

For a self-created node type called 'Event' I added an image field. Got all the modules going ImageCache, Imagefield, IamgeAPI, …. under sitebuilding>ImageCache I made a setting called 'agenda-full-node-thumbnail' (agenda is dutch for calendar by the way) I intended to assign this setting to the image field in Node type 'Event' and succeeded. But now I forgot how I did this.

The problem now is, since I put the site online, my pictures fail to reside in the directory /sites/default/files/imagecache/agenda-full-node-thumbnail and hence giving me a broken image link on my webpage.

Maybe I need to rename the path since I put it online, but can't figure out how I went about making this Imagecache setting and making it work for my Node type to begin with. And that's where I've been stuck for a couple of hours and it's driving me completely nuts.

1

in order to work, imagecache relies on a tmp folder that needs to sit on your server. While developing local the tmp directory is located under the local webserver directory obviuosly and that needs to be changed when you go online. Administer » Site configuration - then file system is where you change it do a directory that is compatible with a server on your host. Setting the permissions to 777 then allowed imagecache to store the necessary image files and solved my issue.

0

Take a look at the handbook on drupal.org -> Troubleshooting Imagecache

Note the section title "What can go wrong? No images in the imagecache directory" Go through the list of items that will guide you to making sure any of the common issues are not the problem. If you don't figure it out then come back and poke us again with any more details you figure out.

Good luck, imagecache in the bomb!

1
  • Thanks DeeZone, I did find the solution to it. I'll post it as the answer
    – Immers
    Sep 26 '11 at 11:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.