0

I have been attempting to import 5,000+ pieces of content from a CSV file using the feeds module. I have it set up to import 130 items every cron run and i have cron running every hour.

All is good for the first few hours. I go to sleep and then wake up, and it is no longer running.

I have my cache clearing every 6 hours. is it possible that clearing cache kills the communication with feeds and stops the import record?

Is it a simple setting change within feeds?

I cannot monitor it completely to see when this issue stops exactly since my imports are suppose to be spread over 48 hours on each hour.

Update: If I run cron manually over and over again, it will reach 100%.

0

you can check your php config php_memory_limit must be at least 128M and max_execution_time 120

also check the error logs go to admin/reports/dblog and check for the errors logged by the server, maybe you can find the problem there

Also make sure you are getting all the errors so you can make a better debug in your issue

Change settings in your site

You can show all errors by adding a few lines to your local testing site's settings.php:

error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);
//Note:  Do not include the opening and closing PHP tags when you copy this code

In addition, navigate to Administration→ Configuration→ Development → logging and errors and select "All messages". (This sets $conf['error_level'] = 2; .)

0

Try adding this to setting.php

$conf['feeds_process_limit'] = 2000;

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.