1

I can't seem to figure out how to enable clean URLs in apache 2.4.6. I have an existing drupal site on ubuntu 12.04 under apache 2.2 and it works just fine. I made a new ubuntu 14.04 server and I managed to get everything installed correctly. I copied over my existing drupal site to the new server and the home page works. No other pages work and I get 404 not found errors because all the links on the site are clean URLs. Could someone point me in the right direction as to how to enable clean URLs? I already enabled the rewrite module... but without success. I can't access my admin or anything on the drupal site on the new server because clean URLs doesn't work...

Here is my .htaccess file:

#
# Apache/PHP/Drupal settings:
#

# Protect files and directories from prying eyes.
<FilesMatch "\.(engine|inc|info|install|make|module|profile|test|po|sh|.*sql|theme|tpl(\.php)?|xtmpl)(~|\.sw[op]|\.bak|\.orig|\.save)?$|^(\..*|Entries.*|Repository|Root|Tag|Template)$|^#.*#$|\.php(~|\.sw[op]|\.bak|\.orig\.save)$">
  Order allow,deny
</FilesMatch>

# Don't show directory listings for URLs which map to a directory.
Options -Indexes

# Follow symbolic links in this directory.
Options +FollowSymLinks

# Make Drupal handle any 404 errors.
ErrorDocument 404 /index.php

# Set the default handler.
DirectoryIndex index.php index.html index.htm

# Override PHP settings that cannot be changed at runtime. See
# sites/default/default.settings.php and drupal_environment_initialize() in
# includes/bootstrap.inc for settings that can be changed at runtime.

# PHP 5, Apache 1 and 2.
<IfModule mod_php5.c>
  php_flag magic_quotes_gpc                 off
  php_flag magic_quotes_sybase              off
  php_flag register_globals                 off
  php_flag session.auto_start               off
  php_value mbstring.http_input             pass
  php_value mbstring.http_output            pass
  php_flag mbstring.encoding_translation    off
</IfModule>

# Requires mod_expires to be enabled.
<IfModule mod_expires.c>
  # Enable expirations.
  ExpiresActive On

  # Cache all files for 2 weeks after access (A).
  ExpiresDefault A1209600

  <FilesMatch \.php$>
    # Do not allow PHP scripts to be cached unless they explicitly send cache
    # headers themselves. Otherwise all scripts would have to overwrite the
    # headers set by mod_expires if they want another caching behavior. This may
    # fail if an error occurs early in the bootstrap process, and it may cause
    # problems if a non-Drupal PHP file is installed in a subdirectory.
    ExpiresActive Off
  </FilesMatch>
</IfModule>

# Various rewrite rules.
<IfModule mod_rewrite.c>
  RewriteEngine on

  # Set "protossl" to "s" if we were accessed via https://.  This is used later
  # if you enable "www." stripping or enforcement, in order to ensure that
  # you don't bounce between http and https.
  RewriteRule ^ - [E=protossl]
  RewriteCond %{HTTPS} on
  RewriteRule ^ - [E=protossl:s]

  # Make sure Authorization HTTP header is available to PHP
  # even when running as CGI or FastCGI.
  RewriteRule ^ - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

  # Block access to "hidden" directories whose names begin with a period. This
  # includes directories used by version control systems such as Subversion or
  # Git to store control files. Files whose names begin with a period, as well
  # as the control files used by CVS, are protected by the FilesMatch directive
  # above.
  #
  # NOTE: This only works when mod_rewrite is loaded. Without mod_rewrite, it is
  # not possible to block access to entire directories from .htaccess, because
  # <DirectoryMatch> is not allowed here.
  #
  # If you do not have mod_rewrite installed, you should remove these
  # directories from your webroot or otherwise protect them from being
  # downloaded.
  RewriteRule "(^|/)\." - [F]

  # If your site can be accessed both with and without the 'www.' prefix, you
  # can use one of the following settings to redirect users to your preferred
  # URL, either WITH or WITHOUT the 'www.' prefix. Choose ONLY one option:
  #
  # To redirect all users to access the site WITH the 'www.' prefix,
  # (http://example.com/... will be redirected to http://www.example.com/...)
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} .
  # RewriteCond %{HTTP_HOST} !^www\. [NC]
  # RewriteRule ^ http%{ENV:protossl}://www.%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
  #
  # To redirect all users to access the site WITHOUT the 'www.' prefix,
  # (http://www.example.com/... will be redirected to http://example.com/...)
  # uncomment the following:
  # RewriteCond %{HTTP_HOST} ^www\.(.+)$ [NC]
  # RewriteRule ^ http%{ENV:protossl}://%1%{REQUEST_URI} [L,R=301]

  # Modify the RewriteBase if you are using Drupal in a subdirectory or in a
  # VirtualDocumentRoot and the rewrite rules are not working properly.
  # For example if your site is at http://example.com/drupal uncomment and
  # modify the following line:
  # RewriteBase /drupal
  #
  # If your site is running in a VirtualDocumentRoot at http://example.com/,
  # uncomment the following line:
   RewriteBase /

  # Pass all requests not referring directly to files in the filesystem to
  # index.php. Clean URLs are handled in drupal_environment_initialize().
  RewriteCond %{REQUEST_FILENAME} !-f
  RewriteCond %{REQUEST_FILENAME} !-d
  RewriteCond %{REQUEST_URI} !=/favicon.ico
  RewriteRule ^ index.php [L]

  # Rules to correctly serve gzip compressed CSS and JS files.
  # Requires both mod_rewrite and mod_headers to be enabled.
  <IfModule mod_headers.c>
    # Serve gzip compressed CSS files if they exist and the client accepts gzip.
    RewriteCond %{HTTP:Accept-encoding} gzip
    RewriteCond %{REQUEST_FILENAME}\.gz -s
    RewriteRule ^(.*)\.css $1\.css\.gz [QSA]

    # Serve gzip compressed JS files if they exist and the client accepts gzip.
    RewriteCond %{HTTP:Accept-encoding} gzip
    RewriteCond %{REQUEST_FILENAME}\.gz -s
    RewriteRule ^(.*)\.js $1\.js\.gz [QSA]

    # Serve correct content types, and prevent mod_deflate double gzip.
    RewriteRule \.css\.gz$ - [T=text/css,E=no-gzip:1]
    RewriteRule \.js\.gz$ - [T=text/javascript,E=no-gzip:1]

    <FilesMatch "(\.js\.gz|\.css\.gz)$">
      # Serve correct encoding type.
      Header set Content-Encoding gzip
      # Force proxies to cache gzipped & non-gzipped css/js files separately.
      Header append Vary Accept-Encoding
    </FilesMatch>
  </IfModule>
</IfModule>

---------------------------here is my vhost file------

<VirtualHost *:80>

    ServerName www.religion-new.byu.edu

    ServerAdmin webmaster@localhost
    DocumentRoot /home/administrator/webroot

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
</VirtualHost>

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerName www.religion-new.byu.edu
    ServerAlias religion-new.byu.edu
    ServerAlias byureligion-new.byu.edu
    ServerAlias www.religion-new.byu.edu
    ServerAlias reled-new.byu.edu

    ServerAlias familyhistorylab-new.byu.edu
    ServerAlias www.familyhistorylab-new.byu.edu

    DocumentRoot /home/administrator/webroot/religion-new.byu.edu
    #<Directory />
    #   Options FollowSymlinks
    #   AllowOverride All
    #</Directory>
    #<Directory /home/administrator/webroot/religion.byu.edu/>
    #   Options FollowSymLinks MultiViews
    #   AllowOverride All
    #   Order allow,deny
    #   allow from all
    #</Directory>
    <Directory /home/administrator/webroot/religion-new.byu.edu/public>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerAlias reledresources-new.byu.edu
    ServerAlias www.reledresources-new.byu.edu

    DocumentRoot /home/administrator/webroot/reledresources-new.byu.edu
    <Directory />
        Options FollowSymLinks
        AllowOverride All
    </Directory>
    <Directory /home/administrator/webroot/reledresources-new.byu.edu>
        Options FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerAlias calledtoserve.byu.edu
    ServerAlias www.calledtoserve.byu.edu

    DocumentRoot /home/administrator/webroot/calledtoserve.byu.edu
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/administrator/webroot/calledtoserve.byu.edu/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:80>

    ServerAdmin webmaster@localhost
    ServerAlias census-new.byu.edu
    ServerAlias www.census-new.byu.edu

    DocumentRoot /home/administrator/webroot/census-new.byu.edu
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/administrator/webroot/census-new.byu.edu/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
    </Directory>
    <Directory /home/administrator/webroot/census-new.byu.edu/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined

</VirtualHost>

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerAlias globalmormonism-new.byu.edu
    ServerAlias www.globalmormonism-new.byu.edu

    DocumentRoot /home/administrator/webroot/globalmormonism-new.byu.edu
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/administrator/webroot/globalmormonism-new.byu.edu/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>
    <Directory /home/administrator/webroot/globalmormonism-new.byu.edu/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    ServerAlias paftutorial-new.byu.edu
    ServerAlias www.paftutorial-new.byu.edu

    DocumentRoot /home/administrator/webroot/paftutorial-new.byu.edu
    <Directory />
        Options FollowSymLinks
        AllowOverride None
    </Directory>
    <Directory /home/administrator/webroot/paftutorial-new.byu.edu/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride None
        Order allow,deny
        allow from all
    </Directory>

    ErrorLog ${APACHE_LOG_DIR}/error.log

    LogLevel warn

    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>

<VirtualHost *:443>
    DocumentRoot /home/administrator/webroot/religion-new.byu.edu
    ServerName religion-new.byu.edu
    ServerAlias byureligion-new.byu.edu
    ServerAlias www.religion-new.byu.edu

    <Directory />
        Options FollowSymLinks
        AllowOverride All
    </Directory>
    <Directory /home/administrator/webroot/religion-new.byu.edu>
        Options FollowSymLinks MultiViews
        AllowOverride All
        Order allow,deny
        allow from all
    </Directory>

    ErrorLog /var/log/apache2/error.log

    LogLevel warn

    CustomLog /var/log/apache2/access.log combined
</VirtualHost>

<VirtualHost *:80>
    ServerAlias 261.byu.edu
    redirect permanent / http://familyhistorylab.byu.edu/261
</VirtualHost>

<VirtualHost *:80>
    ServerAlias fore.byu.edu
    ServerAlias www.fore.byu.edu
    ServerAlias friendsofreligiouseducation.byu.edu
    ServerAlias www.friendsofreligiouseducation.byu.edu
    redirect permanent / http://religion.byu.edu/fore
</VirtualHost>
  • 2
    Any chance you can post your vhost conf? Do you have AllowOverride enabled? And mod_rewrite installed and enabled? – Clive Jun 24 '14 at 19:10
  • A good way to test is to add a bunch of garbage to your .htaccess file. If it throws a 500 server error then its using the htaccess, if not then your AllowOverride may not be set in the vhosts or other conf files. – chadpeppers Jun 24 '14 at 21:00
  • just posted my vhost file – evaldez Jun 24 '14 at 22:30
  • Was I helping you on IRC today with this? – mpdonadio Jun 24 '14 at 23:07
  • 1
    Everything from calledtoserve.byu.edu down is AllowOverride None. If the problem is on one of those domains, that's causing it – Clive Jun 24 '14 at 23:20
4

As mentioned by the others, you'll need to include

AllowOverride All

In the appropriate <Directory> stanza for your Drupal document root. Currently it looks commented out.

Otherwise .htaccess won't be read and the rewrite rules won't be applied.

It looks like you have two+ VirtualHost definitions with the same ServerName, you should also consolidate those to one.

Lastly, ensure mod_rewrite is enabled.

e.g:

sudo a2enmod rewrite
  • add the hostname to your etc/hoosts and all shuld be fine – Josh Aug 30 '14 at 8:41
2

Enable mod_rewrite for Apache

a2enmod rewrite

Now edit the 000-default.conf located at /etc/apache2/sites-available/

nano /etc/apache2/sites-available/000-default.conf

Add the below mentioned lines just under DocumentRoot /var/www/html

    DocumentRoot /var/www/html
    <Directory /var/www/html>
        AllowOverride All
        Order Allow,Deny
        Allow from all
    </Directory>

This will add AllowOverride within the default website configuration

Make sure .htaccess is in the default web directory!

ls /var/www/html/.htaccess

If nothing shows after using the above command, download Drupal again and copy the .htaccess file to that directory

You're done!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.