0

When I create a new content or update existing content gets index immediately on solr search api index. But I have added custom field to search index using entity_info_alter I have added custom field. The custom field gets updated on Solr only on cron job runs. I want it to update when I create/update any content.

How it can be achieved?

1

I think this is the expected behavior: Content is marked to index when you update it, and the next cron run will reindex your items.

You need to enable the checkbox "Index items immediately" for this to be a immediate operation. Be aware this is a costly operation.

enter image description here

If your field type is custom, you might need to expose the value you want to entity API. Check out how to do this in Describe field properties to make custom fields work with Entity Metadata Wrappers.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.