1

I have a custom theme that I have created, that contains a .info file, and various .tpl.php files. The problem is that these templates wont be recognized by Drupal (7). I've tried clearing all of the caches and re-uploading the files with no avail, as well is restoring the database.

This theme works fine on a local server, but whenever the site is migrated to my staging server, the template is not recognized. The theme will show up in the admin interface under the appearance tab however and is enabled as default.

There are no errors in "recent log messages"

4
  • 1
    are the files/directories readable by your webserver? eg, check what user owns them and their permissions etc...
    – Jimajamma
    Jun 26, 2014 at 3:30
  • current permissions for the files are my-user-account:www-data 664 the directory is the same with 775 permissions
    – aonline1
    Jun 26, 2014 at 3:37
  • Were they earlier in some other location and they were moved to the templates folder recently?
    – Gokul N K
    Jun 26, 2014 at 7:05
  • I know you said you've cleared the cache, but have you tried checking "Rebuild theme registry on every page." within the "Theme development settings" of your theme? You can also just clear the registery using the drush command "drush rr" Jun 26, 2014 at 7:57

1 Answer 1

0

It turns out there were more .tpl.php files in a different directory that was not obvious, thus overriding the templates I intended to use.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.