0

I have exported a DrupalGardens site to my own shared hosting and found that the multiple-image uploader not working on exported Drupal Gardens site - what are most likely causes in shared hosting?

The details are below, and I am aware that the uploader uses the plupload multiple file uploading libraries and the Acquia-written drupal module, media. Are these modules "sensitive" to shared-hosting, or what is the most likely thing to cause them to break?

I have also raised a ticket about this with Drupal Gardens and my hosting company (PinchHost) but wanted to know draw upon the expertise of this forum as to what the most likely cause of the problem is and how to solve it.

( The problem is also a forum post I have made here (you can read this: http://www.drupalgardens.com/content/gallery-multiple-image-file-uploader-does-not-work-exported-site-own-hosting )

The problem description:

Here is a screenshot of what I see when I try to upload multiple files in a gallery (what you see here is the broken uploader): http://i55.tinypic.com/14lk6s7.jpg

(It's not the usual pop-up multiple file uploader that I saw when the site was hosted on DrupalGardens themselves.)

My analysis so far...

So I have set about attempting to debug the problem (or at least give Drupal Gardens staff some clues as to what the problem may be). So I compare html source for the above "broken" uploader and the working page seen on my site hosted with Drupal Gardens and on my Acquia Dev Desktop, here is the comparison in Beyond Compare:http://i56.tinypic.com/kbw095.png

You can see from the above comparison screen shot that there are a lot of things missing from the broken version that should be there. I don't know the detail of the inner workings of the uploader, all I can say is that there are things missing as you can see.

Here are the files themselves for you to examine: http://arttravelmedia.com/files/notworking_uploader.htm http://arttravelmedia.com/files/working_uploader.htm The problem that this ticket is about is also a drupalgardens forum post here: (no solutions however, hence this ticket being raised): http://www.drupalgardens.com/content/gallery-multiple-image-file-uploader-does-not-work-exported-site-own-hosting

closed as off topic by tim.plunkett Nov 28 '11 at 0:59

Questions on Drupal Answers are expected to relate to Drupal within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

1

checkout the media module again, they are currently doing a sprint and fixing a lot of issues. Possibly a newer version will fix your problem

  • +1 @uwe999 Thanks that's worth considering. Other things would be to ensure my hosting complies with Drupal requirements i.e. php, mysql and apache versions – therobyouknow Sep 30 '11 at 13:49
  • Another thing to try would be to debug the code - see my question about how to do this here: drupal.stackexchange.com/questions/12349/… – therobyouknow Sep 30 '11 at 14:35
1

This is now solved.

Summary, I used solutions to other problems in the Drupal Gardens 'export sites' sub forum ( http://www.drupalgardens.com/forum/exported-sites ), because I noticed that my site also had some of those problems too which lead me to believe that the root cause was not focused specifically on the gallery uploader.

MY solution is posted here: http://www.drupalgardens.com/content/gallery-multiple-image-file-uploader-does-not-work-exported-site-own-hosting

...and quoted here for convenience:

"Here are all the steps I tried. At the moment I am not sure if all of them are necessary but because they are simple to do then it is worth trying if you are having the same problem as me:

  1. Javascript "issue". Bit vague but solution is to clear local browser cache and clear Drupal's own caches - how to clear Drupal's own cache is stated here: http://www.drupalgardens.com/content/exported-site-behaving-differently (Configuration->Performance)

  2. Javascript aggregation - disable this as described in same post above http://www.drupalgardens.com/content/exported-site-behaving-differently File permissions.

  3. Check correct file permissions of export site on own hosting and adjust if necessary, as discussed here: http://www.drupalgardens.com/content/exporting-site-no-filesthemes-show-permissions-directories-odd (mine were fine except that the overall public_html was 750)"

I can also confirm that my hosting meets or exceeds the Drupal requirements for versions of PHP, MySQL, Apache. Also, I did not need to upgrade Drupal or any modules to a later version that what was exported (as suggested by @uwe999 - worth considering +1 thanks, however! :) ).

Not the answer you're looking for? Browse other questions tagged or ask your own question.