I've got a problem with the dynamic address field. Maybe it is a problem with the feed-importer, not quite sure about that.

I've imported customers to my database, in the view, name and address are displayed correctly but when i click on edit, those fields are empty. Seems like they are correct in the database.

  • Make sure that the country is correctly set, addressfield depends on the country to display the structure.
    – pcambra
    Commented Jun 30, 2014 at 9:28
  • Thanks. That did the trick. Any chance to save addresses without a country?
    – Andi
    Commented Jun 30, 2014 at 10:34
  • @pcambra Looks like your comment should be upgraded to an answer! Commented Jul 12, 2014 at 7:21
  • I think already did :)
    – pcambra
    Commented Jul 12, 2014 at 10:31

1 Answer 1


Addressfield module depends on the country for displaying the right structure of the form that is configured by the plugin, I'm afraid country is mandatory so you can just select one in the field settings so you don't have the selector, then you'll need to do some theming magic for hiding it when it's displayed

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.