0

I installed Drupal on my VPS, but it seems that all input on website doesn't work from web interface. What I mean by that:

  • I cannot login by using web interface

  • I CAN login by using one-time login link generated by Drush, but then strange things happen, I guess consequences of not working input - like Admin Menu disappears after refresh, and editing any content is impossible, after sending change - the edit page simply refresh with old values,

  • I have Redmine installed on this server and it works ok, so it seems to be Drupal specific.

  • The problem doesn't exist with "?q=/user/login" - it exists only with rewritten links. I'm pretty sure I have unmodified .htaccess.

  • The problem exists when I remove from .htaccess everything, with the exception of: ErrorDocument 404 /index.php and RewriteEngine on (which is bare minimum for rewriting to work it seems).

  • There are absolutely no errors in logs of Drupal, Apache and MySQL.

My Virtual Host: http://pastebin.com/R5hRQMWc

My .htaccess: http://pastebin.com/xM5Kj1yd

System: Ubuntu 14.04, Apache 2.4.7, PHP 5.5.9-1ubuntu4.2 , mysql Ver 14.14 Distrib 5.5.37

Any ideas what is going on and why only Drupal is affected?

  • I'm pretty sure I have unmodified .htaccess, then The problem exists when I remove from .htaccess everything. So you have or you haven't modified .htaccess, which is it? ;) – Clive Jul 2 '14 at 13:47
  • This website have few months, when you are busy, after few months you are not sure of anything ;) . – Łukasz Zaroda Jul 2 '14 at 14:51
1

Maybe Apache server doesn't include "mod_rewrite".

Try do below code in the console:

sudo a2enmod rewrite
sudo service apache2 reload

I think this help to you!

| improve this answer | |
  • Wow, that was it! I didn't think about it for a moment, because "pretty urls" were actually working. Thanks! – Łukasz Zaroda Jul 2 '14 at 14:50
1
  1. Check that mod_rewrite is enabled by going to ?q=admin/reports/status/php and searching for mod_rewrite. If it isn't in the list of "loaded modules", ssh into your server and do "sudo a2enmod rewrite", and then "sudo service apache2 restart".
  2. If that didn't help, go to /etc/apache2/sites-available and locate and edit the .conf file for your site. using, say "vi FILENAME.conf". Make sure it contains something like:

<Directory /path/to/drupal>
AllowOverride All Order allow,deny allow from all </Directory>

If you change the .conf file, you'll have to restart apache again, to make it take effect.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.