2

The scheduler changes the node's language to default-language while publishing.

This happens if the scheduler is run by drupal's cron (called by system-cron or manually) and scheduler's lightweight cron (called by system-cron), but if i start the scheduler's lightweight cron manually by admin-interface it's published with the correct language settings...

It happens on both, single nodes and on translated nodes.

I tried for hours with different settings and configurations. The problem occurs on 2 big sites (with 3 languages), but not on 1 low-level site (with 2 languages).

Any idea?

2 Answers 2

0

Find the difference between your low level site and the big ones. Perhapsyoushouldcompare their node tables once before and once after you have published content onthem. Make shure, that the modules and settings are the same while running these tests.

0

I recall someone else having this problem. It was not actually caused by scheduler directly, but another module had a problem in hook_node_load() or hook_node_update() - both of which are called via actions_do() when scheduler runs during cron.

Check to see which modules are enabled on your big sites and not on the small one, then one by one disble the modules and test Scheduler cron, until the problem does not occur.

Jonathan Scheduler module maintainer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.