-1

I've been able to get the Flexslider module + library to work on local dev instances of core Drupal in the past, but when I try to enable/configure for Acquia cloud, it inserts the images as li's but does not animate them.

These are the steps I've taken:

  • Installed/enabled the flexslider module on my local dev environment.
  • Downloaded and installed the latest Flexslider library from github into docroot/sites/all/libraries/flexslider.
  • git added/committed/pushed the changes to Acquia cloud.
  • Enabled the module in the Acquia cloud dev environment.
  • Edited the 'basic page' content type to use a flexslider field.
  • Created a basic page with a few images in that field.

As stated above, the images get inserted as list items, but do not get animated. It seems like the module is being invoked, but the flexslider js files are not being included in the <head>.

The page in question: http://acquiacloudwwedev.devcloud.acquia-sites.com.

  • You don't load flexislider js files. – Nikit Jul 6 '14 at 21:50
  • The flexslider files are in your document head at acquiacloudwwedev.devcloud.acquia-sites.com/sites/all/libraries/… -- maybe a cache clearing issue after your pushed to the cloud? Also - the link you posted is asking for jquery cycle to be installed, possibly in the libraries folder. – schnippy Jul 7 '14 at 1:13
  • schnippy - The popup about jquery cycle was due to another module, rotating_banner. I've removed that from the page to simplify things. I've tried flushing the cache a few times, doesnt seem to help – Eddie Jul 7 '14 at 20:35
  • nikit - could you clarify your comment? On local core drupal instances I've used in the past, the module seems to automatically added the flexslider js files in the head.. But doesnt seem to be doing so on acquia cloud... – Eddie Jul 7 '14 at 20:36
0

Boneheaded mistake on my part - In the default option set for FlexSlider, I had the "Move" field set to 0. This apparently makes it not animate. Changing it to "1" resolved it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.