0

I'm running with a big problem for hours now and it's driving me crazy, maybe one of you already know the answer.

Drush seems to not want to work on my OSX (10.8.5) with MAMP (3.0.5). When I execute $ drush pmi I get the following output:

Command pm-info needs a higher bootstrap level to run - you will need[error]
to invoke drush from a more functional Drupal environment to run this
command.
The drush command 'pmi' could not be executed.                       [error]
Drush was not able to start (bootstrap) the Drupal database.         [error]
Hint: This may occur when Drush is trying to:
 * bootstrap a site that has not been installed or does not have a
configured database. In this case you can select another site with a
working database setup by specifying the URI to use with the --uri
parameter on the command line. See `drush topic docs-aliases` for
details.
 * connect the database through a socket. The socket file may be
wrong or the php-cli may have no access to it in a jailed shell. See
http://drupal.org/node/1428638 for details.

Drush was attempting to connect to: 
 Drupal version        :  7.28                                      
 Site URI              :  http://default                            
 Database driver       :  mysql                                     
 Database hostname     :  127.0.0.1                                 
 Database username     :  root                                      
 Database name         :  db_name                             
 PHP executable        :  /Applications/MAMP/bin/php/php5.5.10/bin/ 
                          php                                       
 PHP configuration     :  /Applications/MAMP/bin/php/php5.5.10/conf 
                          /php.ini                                  
 PHP OS                :  Darwin                                    
 Drush version         :  7.0-dev                                   
 Drush temp            :  /tmp                                      
 directory                                                          
 Drush configuration   :                                            
 Drush alias files     :                                            
 Drupal root           :  /Applications/MAMP/htdocs/drupal          
 Site path             :  sites/default  

I'm running drush in the drupal folder.

I'm using 127.0.0.1 instead of localhost in my settings.php.

I have the following setup in my ~/.bash_profile:

export PATH="/Applications/MAMP/Library/bin:/Applications/MAMP/bin/php5.5.10/bin:$PATH"
export PATH
export DRUSH_PHP="/Applications/MAMP/bin/php/php5.5.10/bin/php"
export PATH=/usr/local/bin:$PATH

I've also created a symbolic link to mysql as follows:

$ sudo mkdir /var/mysql
$ sudo ln -s /Applications/MAMP/tmp/mysql/mysql.sock /var/mysql/mysql.sock

If I run:

$ php -i | grep php.ini

I get:

Configuration File (php.ini) Path => /Applications/MAMP/bin/php/php5.5.10/conf
Loaded Configuration File => /Applications/MAMP/bin/php/php5.5.10/conf/php.ini

Which means I'm using the same PHP version either in my apache server than in drush.

Now, I have no clue whatsoever on why drush is not properly working. Maybe one of you have an answer for this and hopefully for all of us who might have encountered this problem.

Thanks in advance!

1

I had the same issue, after so much researching this linked answered it.

http://julianlmedina.com/getting-drush-working-with-mamp-3-on-mac/

it worked for me, I hope it'll for you as well.

0

What url do you use to access this Drupal site? I notice that drush reports Site URI as http://default. This is not necessarily a problem (I have multiple working sites running on a MAMP server, and this is what they report too), but what do you get if you re-run the command with the --uri flag?

drush pmi --url=example.local

If that does make things work, you can create a drush alias file as shown below and use drush @example pmi to run commands:

$aliases['dev'] = array(
  'root' => '/path/to/example.local',
  'uri' => 'example.local',
);

For the record though, I've never needed to do this when using MAMP--but I do create virtual host records for all local development sites so that may be a factor.

  • Hi @bhotel, thanks for your suggestion, but I already tried that and nothing changed. Indeed I noticed the http://default but looking online I noticed everyone has that as their Site URI from the drush status. I also tried with an alias and nothing changed. – Dani Jul 10 '14 at 9:53
0

Specifying my port and 127.0.0.1 in settings.php in addition to following every step in this authoritative article and specifying my version of Drush as Drush 7 worked for me. Long slog (been through the same issue twice).

  'host' => '127.0.0.1',
  'port' => '8889',

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.