I've enabled the Locale and Content Translation module but am having trouble understanding how to do something that it seems should be working.

Basically I have a page, we'll say '/about' and it's in English.

I click translate, I have a few languages enabled, so I click to add translation for Japanese. It brings up the interface for making a new page. I change some stuff to Japanese, and set the URL alias to be /about ('about') like the english page.

I've setup my language options to use the "Session" detection method.

The result I'm wanting to achieve, but not getting is to have:

www.example.com/about -- to go to english (this works)
www.example.com/about?language=ja -- to go to the Japanese translation, this does not work, it just loads up the English page.

It seems like this would be the normal functionality so I feel like I'm missing something here.

  • belongs on drupal.
    – Daniel A. White
    Commented Sep 29, 2011 at 1:51
  • www.example.com/ja/about ?
    – Nikit
    Commented Sep 29, 2011 at 5:00
  • there are 4-5 methods of selecting a language. That is using the 'URL' option. I'm referencing the 'Session' option.
    – John
    Commented Sep 29, 2011 at 5:59

2 Answers 2


just to be sure: at admin/config/regional/language/admin_language, enable "Session" Detection method make sure request/get parameter set to language make sure you have about page in 'ja' language

try to visit yoursite.com/?language=japanese, it should be translating interface/etc - this way you can check translation is working.

  • I don't have any interfaces translated currently (I don't display any standard drupal interfaces to regular users anyway). I have Session enabled, and there is a 'ja' version of the page, it even gives me a link to the Japanese version at the bottom of the page, but it links directly to the node so something like /node/123?language=ja instead of /about?language=ja. I setup the URL alias but can't seem to access the japanese page with it by default.
    – John
    Commented Sep 29, 2011 at 15:15
  • /node/123?language=ja what this url is displaying? translated node? try to clear cache at performance page, maybe this will help.
    – 32i
    Commented Sep 30, 2011 at 10:57

It seems the Content Translation module is out-dated and was replaced by Entity Translation. Content Translation doesn't seem to work with the Session Detection method (at least with URL Aliases), but Entity Translation works fine with it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.