1

The ckeditor on my site suddenly stopped working without changing anything.

This is what I tried up to now:

  • update all other modules and drupal core
  • remove ckeditor
  • clear caches of drupal and browser
  • download the latest drupal ckeditor module
  • download the latest ckeditor full version and copy it in ckeditor/ckeditor
  • copy all to modules/ckeditor
  • check if ckeditor.config.js is their.
  • turn module on
  • check status report -> no error
  • set permission -> admin -> full html

PROBLEM: ckeditor is not showing nor is its configuration (admin/config/content/ckeditor).

**extra info* jquery version 1.7 using the default compression level production jQuery and jQuery UI CDN none*

Non of the answers found on this site concerning this subject has been of help yet. I tried using firefox and chrome.

Thanks in advance.

  • Really odd, you're doing everything correct. Unless somehow the database table is screwdup. When you say "removed" the module, did you not only disabled it, but uninstalled the module? When you uninstall it, it removes its tables from the database. – No Sssweat Jul 16 '14 at 8:04
  • Also, when you turned module on, did you check that is indeed on? maybe it's not turning on for some reason? – No Sssweat Jul 16 '14 at 8:13
0

You have done everything I would have done.

Try a different path to ckeditor library. Install the libraries module and put the ckeditor library under libraries/ckeditor/ckeditor.js.

Try uninstalling the Drupal CKEditor module and go with the WYSIWYG module and see if that helps.

Also, try with different versions of jQuery. Sometimes the newer versions (1.9+) conflict with a lot of modules, though 1.7 which you are using is the sweet spot I have found.

And lastly try with an older version of CKEditor plugin.

0

1- See in libraries folder and check Ckeditor library.

2- With firebug see consule tab for javascript errors and fix them.

3- Config Ckeditor in drupal.

-- config permissions.

-- Config profiles use from Ckeditor in this path: admin/config/content/ckeditor

-- Text format of Editor: - plain text. - full html or filtered html when create content.

See this links:

https://www.drupal.org/node/1154602

Ckeditor doesn't work

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.