1

I added font using @font-your-face module and everything works just fine except when 'Aggregate and compress CSS files' is enabled. When I enable css aggregation and compression, whole website use some default font instead imported font in @font-your-face.

Does anyone have problem like this? Some suggestions how to resolve this?

4
  • Try AdvAgg
    – mikeytown2
    Commented Jul 14, 2014 at 22:50
  • 2
    This question appears to be off-topic because it is a bugreport for @font-your-face. You asked here, you got your answer, but are module maintainers notified? Have you made sure they know there is an issue? Seems not, so other people will still use this module with bug. Please don't divide bugfixing efforts - bugs belong to issue queue, because that's a way to make bugfixes available to as many people as possible, as fast as possible.
    – Mołot
    Commented Jul 15, 2014 at 6:48
  • this is probably not bug, I'm using exactly the same version of @font-your-face on many other websites and there is not any problem like this...
    – mixerowsky
    Commented Jul 15, 2014 at 8:50
  • I tried AdvAgg but without success...
    – mixerowsky
    Commented Jul 15, 2014 at 10:50

1 Answer 1

0

After your compress the CSS using Aggregate option in Drupal, viewing the source code you'll find that there is an syntax error for @font-face.

Check for your syntax, there would be a break-age in that while aggregation.

4
  • Yes, you are right, I've checked it and found the issue in the same. Thanks for the solution it worked like charm! Commented Jul 15, 2014 at 6:21
  • I can't find any syntax error...
    – mixerowsky
    Commented Jul 15, 2014 at 8:59
  • OK, remove everything except from CSS file except @font-face and then try aggregating the CSS and JS. Let me know if at that point your font-face works! Also, can you please share your CSS code here? If its too large then paste it somewhere on pastebin and then provide us the URL. Commented Jul 15, 2014 at 9:13
  • my CSS is on pastebin.com/wevqn0uw
    – mixerowsky
    Commented Jul 15, 2014 at 10:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.