0

I have an image field in a content type that uses the image widget. Whenever I select an image to upload, it gives the error: "An illegal choice has been detected. Please contact the site administrator."

The image thumbnail appears as normal, however, there is no way to submit the form (returns errors) and you can't add more images.

I haven't made any changes to the form (just some CSS stuff for presentation).

How can I fix this?

5
  • of course configuration of your Image field was reviewed. or not?
    – cigotete
    Sep 30 '11 at 20:15
  • naturally. The interesting part is that I have it working on a different content type just fine. I've compared the settings side by side and they seem identical. I'm hoping someone has experienced something similar ... I also had a text field that could take unlimited, and I would get the same error. It appears that it's related to the widget and something in the content type is messing it up.
    – gregghz
    Sep 30 '11 at 21:49
  • Also, when I try to use the existing (working) image field in the new content type, it also doesn't work (but remains workings in the old content type). It's clearly related to the context of the new content type, but settings appear to be identical.
    – gregghz
    Sep 30 '11 at 21:53
  • may be they seem identical because is the same field. is shared between two or more content types, and the specific configuration of the field was changed with data/configurations already stored.
    – cigotete
    Oct 1 '11 at 2:19
  • well i tried it with two different fields. One was the exact same field (shared). The other was not. Neither method worked.
    – gregghz
    Oct 2 '11 at 23:43
2

I had similar issue, fixed it by changing one of my required field from radio buttons to "select list".

1
  • Turns out that I resolved this a while back in a similar way. I forgot this question was up >.< I can't remember exactly which fields I changed, but the image uploading wouldn't work if certain other typs of widgets were present. Is this a bug?
    – gregghz
    Mar 8 '12 at 18:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.