0

I'm using proximity search in views 3.

The proximity search is by Postal Code.

When first loading the view page, it's showing all result. In my case this is not good because the postal code is required for filtering.

My question is.

Is there a way to not showing all the result when postal code search field is empty.

Here is a screen shot of my views Criteria.

enter image description here

In More Thanks a lot

  • Try changing the Exposed form style to Input required. – Andy Jul 24 '14 at 12:26
  • it's not working... – Jean-Francois Jul 24 '14 at 12:31
0

In the settings for the exposed search field, you should be able to change the behaviour: On Empty input, Show None. Show All is set by default

  • Sorry, I didn't find where it is ? – Jean-Francois Jul 24 '14 at 10:26
  • Under FILTER CRITERIA, you should have a field that it is using to search by, and it should be an exposed filter. clicking on the settings for that field should bring up the option to include an On Empty input, where you change the behaviour when nothing is entered – Geoff Jul 24 '14 at 11:48
  • I did a screenshot of What I'm seeing, I'm I at the right place – Jean-Francois Jul 24 '14 at 11:58
  • it looks like it overwrites some of Views default behaviour. The option doesn't appear to be there. It might need to be a feature request for the module – Geoff Jul 24 '14 at 12:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.