0

I am trying to fix a site, which I did not build nor 'break'.

On a clean install of Drupal, the markup for a node's textfield, set to display inline, looks like this:

<div class="field field-name-field-foo field-type-text field-label-inline clearfix">
  <div class="field-label">Foo:&nbsp;</div>
  <div class="field-items">
    <div class="field-item even">Bar</div>
  </div>
</div>

On my problem site it looks liike this:

<span class="field-label">Foo: </span>
<div class="field field-name-field-foo field-type-text field-label-inline inline">Bar</div>

I have turned off the custom theme and I have disabled the Display Suite module, cleared all caches - no change.

Are there any other obvious places I could look to find what is changing the outputted markup?

There are 250 modules enabled, so turning things off one by one is not really an option.

Thanks.

2
  • 3
    See if they have a module called fences Jul 23 '14 at 17:06
  • If they do have fences installed you can edit the field and change the wrapper markup to 'Default'; it should go back to normal
    – Clive
    Jul 23 '14 at 18:28
0

Yes, it was the configuration of the fences module. I needed to cancel the override in the first section. Navigate to Fences configuration to change the settings.

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.