0

As I know so far Drush has some limitation on Windows. I need however, to get it working, and I have activated the curl module in php.ini. All you need is to uncomment the line:

extension=php_curl.dll

Now, I run phpinfo.php and it seems curl is activated, but I still get the console error:

wget or curl executables not found.

I have restarted the Apache server several times but still no way out.

Is anyone able to help me up?

closed as too broad by kiamlaluno Dec 22 '17 at 14:18

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

3

The problem was with the php.exe path in drush.bat

The solution is to properly edit it. In my case ( I use xampp ) here is the path:

@echo off
REM See http://drupal.org/node/506448 for more information.
@c:\xampp\php\php.exe "%~dp0drush.php" %*
1

Are you sure you're editing the correct php.ini file? Drush is a command line tool, and when PHP runs on the command line, it usually uses a different php.ini file than the PHP running under Apache (or any other web server).

To test if curl is enabled in command line PHP, run this command:

$ php -i | grep -A 3 'curl'

In my case (Ubuntu 11.04), the output was:

/etc/php5/cli/conf.d/curl.ini,
/etc/php5/cli/conf.d/gd.ini,
/etc/php5/cli/conf.d/mcrypt.ini,
/etc/php5/cli/conf.d/mysql.ini,
--
curl

cURL support => enabled
cURL Information => 7.21.3

which means that curl is enabled.

To check which php.ini file your command line php uses, run:

$ php -i |grep php\.ini

In my case, the output was:

Configuration File (php.ini) Path => /etc/php5/cli
Loaded Configuration File => /etc/php5/cli/php.ini

On Windows, the values will be different but the idea is the same.

  • I found the solution: drush reads a bat file called drush.bat. It contains the path to php bin folder, in my case the default path was not the real one. I change it and voila! Here is the line that needs editing: @c:\xampp\php\php.exe "%~dp0drush.php" %* – drupal_stuff_alter Oct 3 '11 at 13:35
  • 2
    Good to see you solved your problem. On Stackexchange, the 'right' way to add your solution to this page, is to add another answer. After 48 hours, you can even mark your own answer as accepted. – marcvangend Oct 3 '11 at 13:44
0

I know this has already been answered, but in case it helps somebody: I came here searching for a solution to the same error (wget nor curl executables found.), but the accepted answer did not work for me.

After a little more digging and testing, what turned out to be the cause of the problem is that the cygwin binaries folder had not been added to my windows environment path variable (System Properties > Advanced > Environment Variables > System variable > Path).

In my case, the path to add was C:\cygwin64\bin. And now it works. :)

-1

Turn "allow_url_fopen" off in your php.ini file

Not the answer you're looking for? Browse other questions tagged or ask your own question.