0

I've created a D7.29 test site on godaddy's "deluxe classic hosting" plan at www.mybusiness.com/test and it works great. The site structure is root\mybusiness\test. Now I've been trying to copy it to the root and direct a client's web domain to that copy and now all the user gets is the first page (very quickly I might add, like it was a static page) but all links that you click on or when trying to log in just result in "Internal Server Error..."

I then tried to direct the client's domain www.hissite.com to the original test site's folder at root\mybusiness\test and all it results in is the same error, even after waiting an hour.

I then read about the settings.php option of base_url = 'http://www.hissite.com'; so I enabled that and still get the same error. What's wrong? How come I can't just direct a domain to a working Drupal instance?

Any help would be greatly appreciated!!

Dave N

1

Fundamentally, there is absolutely no problem with pointing a domain to a functioning Drupal instance. That being said, there are many other things that can be going on here. Let's tackle a few of them.

  1. First of all, when you change the DNS settings for a domain, it can take a day or more to fully propagate, due to the way different DNS servers cache their entries. To make matters worse, the change can make it to you at a different time than someone else, which makes it difficult to detect what is going on.

    If you want to see results immediately for testing, then you need to manually add an entry to your hosts file that points the domain name to the server that you want to see the results for. In a Linux machine, the hosts file is /etc/hosts, and on a Windows machine, it is \Windows\System32\drivers\etc\hosts. You add an entry just by adding a new line to the end of the file in the form of:

    XXX.XXX.XXX.XXX www.hissite.com

    where the XXXs are the IP address of the target server. The change is instant when you save the hosts file (i.e. no need to restart).

  2. $base_url is a setting that affects how Drupal creates URLs internally. If the links that Drupal is creating look correct (e.g., www.hissite.com/node), then it is working correctly.
  3. This could be a problem with clean urls. If you go to www.hissite.com?q=user, and that works, but www.hissite.com/user does not, then the server is not correctly interpreting clean urls. Your only options are to either enable clean urls or to choose a different host, since you likely don't have direct access to the server settings. (Disclaimer: I haven't used GoDaddy's service, so I don't know the extent to which you can modify server settings.) Basically, if the server is running Apache, then, in order for clean urls to work, Apache must be allowed to parse your .htaccess files, and it must have mod_rewrite enabled.
  4. A final test would be to see if perhaps the .htaccess file is not being interpreted at all. Try going to www.hissite.com/index.php?q=user. If that works, but www.hissite.com/?q=user does not, then it is definitely a server setup issue, and I do not know if GoDaddy provides you with the tools to fix it.

Finally, I want to address your fundamental problem as I see it: you are using GoDaddy. I'm slightly biased against them for various reasons, but mostly I think that you can have a better experience for roughly the same cost by setting up your own VPS somewhere. I use DigitalOcean, and have for quite some time (I have no affiliation with them other than being a customer). For the same cost of the GoDaddy deluxe hosting, you can have your own small VPS which can run several sites. I do this with my personal site, http://cscrunch.com, as well as a handful of other, family sites.

2
  • Thanks. What you mentioned got me thinking and experimenting. I experimented by making a good instance of Drupal at /mysite/test and made a subdomain to point to that folder. It didn't work (test.mysite.com didn't work except for the front page) but when I went to www.mysite/test it did work and navigating to all links worked. So then I went back to test.mysite.com/?q=user and it indeed worked. I think it's the htaccess file. I read about that and made 2 changes: RewriteBase /test/ and also uncommented this line when that didn't work: RewriteBase / THanks for the help. Film at 11.
    – Dave N
    Jul 25 '14 at 19:52
  • Perfect!! It all works now.
    – Dave N
    Jul 26 '14 at 5:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.