-1

My Drupal 7 website is throwing 500 internal server error, when I try to log in as Admin.

I checked the apache error log it throws below error

 PHP Fatal error:  require_once(): Failed opening required '/*****/******/sites/all/modules/context/context_ui/export_ui/context.inc' (include_path='.:/usr/share/pear:/usr/share/php') in /******/******/sites/all/modules/ctools/includes/plugins.inc on line 480, referer: http://*******/user

What could be the problem ?

Thanks

7
  • 1
    is context module present in sites/all/modules folder ?
    – shrish
    Commented Jul 29, 2014 at 9:46
  • @shrish is right - is this file present? With proper permissions? What have you changed before this started?..
    – Mołot
    Commented Jul 29, 2014 at 10:14
  • i have not changed it .... it works in my local but in my dev environment server it is not working
    – Hitesh
    Commented Jul 29, 2014 at 10:25
  • try installing context module again, may be some file is missing while copying.
    – shrish
    Commented Jul 29, 2014 at 10:36
  • ok, let me try. but it works in my local but not in my dev server
    – Hitesh
    Commented Jul 29, 2014 at 10:40

1 Answer 1

0

Can you confirm which version of php you are using? I just realized that the magic php constant "DIR" (which I first used here in beta4) may only work in php versions 5.3 or greater, so I'm guessing you have a version that's below v5.3.

According to the Drupal requirements, the PHP requirement for Drupal 7 is "PHP 5.2.5 or higher (5.3 recommended)", So I may have made a mistake by introducing a construct that's not compatible with some php versions that Drupal 7 still supports. I'll need to fix this, but either way if you can confirm your php version that would be very helpfu

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.