3

I have setup Fuzzy Search in our website to provide 'intelligent' search functionality. I believe that the setup is all proper but despite the fact, I always get back 0 results. This is my search page for Fuzzy Search:

http://indiansnakes.org/search-fuzzy

I have exposed "Fulltext search" and I have indexed few key fields of the snake nodes from the website which has to be searched upon (like Common name, scientific name, snake description etc.)

I have setup Search Server for Fuzzy search as shown below:

Something fishy about the database here?

Minimum word length = 3.

I would also like to know if there is a way to provide a dedicated database for Search server and it's indexed data?

Next, I have setup Fuzzy Search index which shows that the items have been indexed and it looks like this:

Fuzzy Search Index

I have setup the Views for Fuzzy Search page like this:

Still Search does not work!

Despite all this, my Fuzzy Search does not give back any results. Any idea what might be going wrong here?

3
+100

In the Fuzzy Search index, make sure the Fuzzy Search processors are enabled, and that they are processed last. The Fuzzy Search except processor should be last, with the settings processor immediately before it. You may need to enable the Tokenizer processor as well, and that should be before the Fuzzy processors.

Reindex after saving the changes.

| improve this answer | |
  • How do I make sure that Fuzzy Search Processors are enabled? Where do I see the processors' settings? – Raj Pawan Gumdal Aug 14 '14 at 11:51
  • Indeed! That was it! The ordering was very important which I had missed out. Thanks a ton for your answer and thanks Clive for running a bounty on this question. – Raj Pawan Gumdal Aug 14 '14 at 12:03
  • You are most welcome. Happy to help. – faerysteel Aug 14 '14 at 15:02
  • Since you've accepted my answer, would it be possible to get the bounty as well? I understand that has to be manually assigned. – faerysteel Aug 14 '14 at 18:10
  • If it worked, it gets the bounty :) – Clive Aug 14 '14 at 18:39
2

If you've some issues and you don't see your created indexes at /admin/structure/views/add then try to clear you cache. Standard core one and Views cache at /admin/structure/views/settings/advanced

Note that only fields of type Fulltext can be used in fulltext searches. So when you want to find individual words contained in this field, not just the whole field value, use this type. Other types can be used, e.g., for filtering and sorting.

also, you have some javascript errors you may want to look into:

GET http://localhost:8080/socket.io/socket.io.js net::ERR_CONNECTION_REFUSED
search-fuzzy:51

Uncaught SyntaxError: Unexpected identifier
search-fuzzy?search_api_views_fulltext=boa:formatted:293
| improve this answer | |
  • I have cleared the caches many times to make sure that wasn't the issue. Also I have made sure that the fields are mentioned as "Fulltext" which have to be indexed. I did not get the JavaScript error part, can you please explain it a bit on how you could find error in my website and how to resolve it? – Raj Pawan Gumdal Aug 9 '14 at 11:11
  • if you use chrome browser, you can open developer tools (ctrl+shift+i), and then open the console tab – Suing Aug 14 '14 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.