My client drupal site stopped working suddenly and gave me this error Fatal error: Class 'RulesI18nStringController' not found in entity.i18n.inc on line 31 i checked the rules module and entity module and nothing seems to be messing. I searched for a solution on the internet with no luck. I have rules 7.x-2.2 and entity 7.x-1.0-rc3 but i can't login to the site so i can't access update.php to update the rules and entity modules to the latest versions "as it may fix this problem".

So can anybody help me find solve this problem?

PS: If you need any additional information about the problem just ask about it in the comments.

Thanks in advance for you all.

| improve this question | | | | |
  • 1
    You can use drush to update your site without logging in. – Елин Й. Aug 4 '14 at 5:58
  • @ЕлинЙ. i will try it and i hope updating will fix the problem – Muhamad Bhaa Asfour Aug 4 '14 at 6:14

You have $update_free_access variable in your settings.php file. Set it to:

$update_free_access = TRUE;

You will be able to run update.php without login. Don't forget to turn it back to FALSE when done - if left TRUE, it can open your site to DoS attacks.

| improve this answer | | | | |
  • Tried it and updated my modules and the error message is gone thank you for your help – Muhamad Bhaa Asfour Aug 4 '14 at 6:57
  • Glad it worked :) – Mołot Aug 4 '14 at 7:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.