0

I have already file cache module installed and working perfectly except that I've read that it also work with authcache.

So I installed authcache but wondering what is the proper configuration in the settings.php.

In authcache readme file, it gives an example as follows:

$conf['cache_backends'][] = 'sites/all/modules/filecache/filecache.inc';
$conf['cache_backends'][] = 'sites/all/modules/authcache/authcache.cache.inc';
$conf['cache_backends'][] = 'sites/all/modules/authcache/modules/authcache_builtin/authcache_builtin.cache.inc';
$conf['cache_class_cache_page'] = 'DrupalFileCache';

And my current configuration for file cache module is:

$conf['cache_backends'] = array('sites/all/modules/filecache/filecache.inc');
$conf['cache_default_class'] = 'DrupalFileCache';
$conf['filecache_directory'] = '/tmp/scfilecache-' . substr(conf_path(), 6);

I tried to combine the two configuration as follows without luck:

$conf['cache_backends'][] = 'sites/all/modules/filecache/filecache.inc';
$conf['cache_backends'][] = 'sites/all/modules/authcache/authcache.cache.inc';
$conf['cache_backends'][] = 'sites/all/modules/authcache/modules/authcache_builtin/authcache_builtin.cache.inc';
$conf['cache_class_cache_page'] = 'DrupalFileCache';
$conf['filecache_directory'] = '/tmp/scfilecache-' . substr(conf_path(), 6);

My site returns an error with the config above.

Anyone know what is the correct configuration for authcache + file cache?

1

After testing for several settings, I came up with the following configuration:

$conf['cache_backends'][] = 'sites/all/modules/filecache/filecache.inc';
$conf['cache_default_class'] = 'DrupalFileCache';
$conf['filecache_directory'] = '/var/www/clients/client1/web8/tmp';
$conf['cache_class_cache_authcache_key'] = 'DrupalFileCache';

$conf['authcache_builtin_cache_without_database'] = TRUE;

$conf['page_compression'] = 1;

$conf['page_cache_maximum_age'] = 600;

$conf['cache_backends'][] = 'sites/all/modules/authcache/authcache.cache.inc';
$conf['cache_backends'][] = 'sites/all/modules/authcache/modules/authcache_builtin/authcache_builtin.cache.inc';

I am using nginx and just change the $conf['cache_class_cache_page'] to $conf['cache_default_class']. I don't know if I am using the correct config, but this works for me.

And the speed of my server increase significantly when I ab test it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.