3

I am creating a view with a list of titles that link to the relevant full article that is also displayed via a view.

The view that contains the article has a contextual filter which contains the Title and the of the views is "mysite.com/%"

So the article that is named "hello world" will be found at "mysite.com/hello-world"

However if the article has the ' special character in it for example "Children's Book" the link that I create to point at the article will be "mysite.com/Children%26#039;s-Books" which brings back an empty result.

3 Answers 3

1

You can configure under Contextual Filter > More setting. There are some transform settings.

enter image description here

1
  • @gilzeroI don't find any option related remove special characters in setting.
    – webpic
    Commented May 29, 2018 at 5:33
1

With the Pathauto module you can strip the special Chars. Here is a quote about it (from the module's project page):

... automatically generates URL/path aliases for various kinds of content (nodes, taxonomy terms, users) without requiring the user to manually specify the path alias. This allows you to have URL aliases like /category/my-node-title instead of /node/123. The aliases are based upon a "pattern" system that uses tokens which the administrator can change.

1
  • Thanks but I'm sill confused, I am talking about arguments in views rather than the actual alias of the node...unless I am missing something. Commented Oct 5, 2011 at 9:11
0

You can try to override the template for your view, and there escape the string that is sent with urlencode(); assuming that you have the necessary Drupal experience to do that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.