0

Recently all users (except UID 1) lost the ability to add content.

When going to node/add we get the message "no content types created yet"

When going to node/add/page we get "Access Denied, you are not authorized to access this page"

There are people having similar issues like here - https://www.drupal.org/node/1073994

I have already checked the navigation menu to see if that was the issue, since it seems to be a known bug, but this was not the case. All the permissions are set correctly in the permissions UI and database too.

I am not sure if this is relevant, but the site was migrated from 6 to 7

Any insights would be appreciated!

  • While migration, once it was completed have you re-built the permission? In the Reports page you may have seen the link saying Rebuild Permission? – Aneek Mukhopadhyay Aug 17 '14 at 16:02
  • Good idea, We already tried that though. Thanks anyway, Aneek! – Stan Ascher Aug 17 '14 at 19:47
  • Okay, do you have apache solr node access module enabled? I had one similar issue which was related to node access module. – Aneek Mukhopadhyay Aug 18 '14 at 6:17
  • We do have Apache SOLR access enabled, perhaps we should restart our index on our TEST site without it turned on to see if that is the issue. Good call – Stan Ascher Aug 18 '14 at 14:18
  • originally we thought apache solr was the issue, it was not and I am editing this ticket so people can find this info helpful in the future – Stan Ascher Aug 19 '14 at 1:23
0

This is indeed most likely an access issue. However, I don't think it's something with Apache Solr but more with some of the additional modules you might have enabled. Can you list them with the versions here?

Also, as mentioned above, disable apachesolr access and rebuild your permissions. Check if it is still the case?

  • Thanks, Nick. No luck with disabling apachesolr access and rebuilding. I do notice content access enabled... will try disabling and flushing – Stan Ascher Aug 18 '14 at 17:10
  • It was not your work after all, it was ours ;) – Stan Ascher Aug 19 '14 at 1:28
0

The problem was with the node limit module.

Our developer Weiling Gu noticed that the problem started after anonymous users were submitting content.

By process of elimination we discovered that node limit was causing the block.

We have not yet confirmed if a settings change in node limit would have resolved the issue, but at least turning it off solved our immediate problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.