0

I set a few fields as FIELDS section of a view. the problem is when I click on the fields the Style settings ,No results behavior , Rewrite results and More links are not collapsible . this is the screenshot

enter image description here

what it is like that?

closed as too broad by kiamlaluno Nov 11 '16 at 18:39

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • try jquery_update module with jquery version 1.5 for admin pages. – shrish Aug 19 '14 at 16:25
  • @shrish I tried it but it didn't work :( – M a m a D Aug 19 '14 at 16:33
  • make sure your jQuery update and Ctools module is upto date – shrish Aug 19 '14 at 16:45
  • They are, the website was working , suddenly this thing happened! – M a m a D Aug 19 '14 at 16:46
  • Just to be sure, is it the issue that disappears when you open your developer tools widget in your brower? – Djouuuuh Aug 20 '14 at 8:53
3

Apparently you're not the only one to encounter this issue. Here are some similar situations:

It appears that no one has found out the solution yet. It doesn't seem to come from jQuery Update or backend theme. However, these advices show up each time:

  • Make sure that the needed JavaScript file is loaded in the header of the node (collapsible.js)
  • Perhaps a conflict with another module that would use Views hook. Disable enabled modules one by one and test.

If you find which module interferes with Views or why JS file is not loaded, I think you will make more than one happy people.

  • it has got nothing to collapsible.js! this file is not in the sites where they work well – M a m a D Aug 20 '14 at 13:05
  • Does the fieldset have the class "collapsible" like mine? <fieldset id="edit-options-style-settings" class="collapsible collapsed form-wrapper collapse-processed"> – Djouuuuh Aug 20 '14 at 13:14
  • it has these classes collapsible collapsed form-wrapper – M a m a D Aug 20 '14 at 13:57
  • I also have a collapsible-div.js that comes from ctools module. Do you? – Djouuuuh Aug 20 '14 at 14:01
  • No I don't have that js file! – M a m a D Aug 20 '14 at 14:05
0

This mostly happens when you have a javascript error, or using a custom admin theme which doesn't play well with the accordion/fieldset behaviors.

Open Javascript console (Usually F12) to see if there's any errors reported there.

If you're using a custom admin theme, try switching back to Seven theme

  • No javascript error was reported in Firebug, I tried Seven and Bartik, they both it didn't work! – M a m a D Aug 19 '14 at 16:21
0

I've had same problem.

I have custom module in which I have override javascript of contrib module Field group like this:

$javascript[drupal_get_path('module', 'field_group') . '/multipage/multipage.js']['data'] = drupal_get_path('module', 'create_events') . '/js/multipage.js';

When I realized that I've added condition to override js file only on add content type event page or on edit page.

/**
 * Implements hook_js_alter().
 */
function create_events_js_alter(&$javascript) {
    if (request_uri() == '/node/add/event' || node_type_get_name(node_load(arg()[1])) == 'Event') {
        // override default multipage javascript to change button output
        $javascript[drupal_get_path('module', 'field_group') . '/multipage/multipage.js']['data'] = drupal_get_path('module', 'create_events') . '/js/multipage.js';
    }
}

So maybe you can check if you are implementing hook_js_alter function and try to comment that out and try again.

Hope this will help someone.

Not the answer you're looking for? Browse other questions tagged or ask your own question.