1

i have created a new content type but when i go to add content, it does not appear but only appears under content types. I have even tried to clear the caches but all in vein, what could be the cause? i will glad for your help

  • 2
    You do it as which user? And what do you see when you go to example.com/node/add/content_type_machine_name ? – Mołot Aug 22 '14 at 11:59
  • Also, what happens if you try that as UID 1 (aka admin, first user)? – Mołot Aug 22 '14 at 12:15
  • as administrator – mase Aug 22 '14 at 12:21
  • 1
    OK, and what about the other details I requested? Come on, it is your problem, so show some effort in solving it! – Mołot Aug 22 '14 at 12:23
0

Go to structure >> Menus >> Navigation (admin/structure/menu/manage/navigation) and make sure to enable the content type link in that list.

Here I'm showing example for Article Content type.

enter image description here

| improve this answer | |
  • Shouldn't it be "on" by default? – Mołot Aug 22 '14 at 12:07
  • @Mołot As far as I know, If it's a core menu (default content types, Article, Basic Page) Yes, it will be "on" by default. Here I added screenshot for better understand. – Krishna Mohan Aug 22 '14 at 12:11
  • yes i have tried to enable it but still it can't appear i really do not know what has happened. – mase Aug 22 '14 at 12:12
  • @mase see my comment under your question. provide informations I asked about, and we might try to help more. – Mołot Aug 22 '14 at 12:14
  • @mase you have mentioned "i have created a new content type" how did you create that? I think Molot already asked in comment please respond – Krishna Mohan Aug 22 '14 at 12:15
0

Just came across this problem, that is a new content type is not showing under Add content (or node/add) even though it was showing under Content types (admin/structure/types)

Check your modules and their permissions. I found that view_unpublished module has a View any unpublished content permission that prevents that content type displaying completely.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.