1

I seem to have a problem when adding html to a block (i'm using ckk editor), if i toggle Source it loses them html id tag. If I save the Block without toggling, it works fine, but when I go back in to edit the block afterwards, it has lost the div id tag. I have attached a pic which shows the problem in 3 steps. I have it set to Full HTML throughout. enter image description here

1
  • Just use switch to plain text editor link Aug 24 '14 at 15:19
2

I thinks, you must twig ckeditor config file, and set config.allowedContent = true. Please, see docs http://docs.ckeditor.com/#!/guide/dev_allowed_content_rules

This links below can help you.

https://stackoverflow.com/questions/15659390/ckeditor-automatically-strips-classes-from-div

CKEDitor removes class names, even with the exception in config

1
  • thats fantastic, looking at the link you provided, i was initially tempted to dive in and add the line to config.js, but further down in the chain, i found you can amend the settings under "Admin >> Configuration >> CKEditor", this is explained really well in the link. many thanks. Aug 25 '14 at 9:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.