1

When I try editing any pane on my site, I get this:

enter image description here

The following error is in my Web Inspector console:

TypeError: 'undefined' is not a function (evaluating '$('.panopoly-textfield-autosubmit, .panopoly-textarea-autosubmit', context) .once('ctools-auto-submit')')

TypeError: 'undefined' is not a function (evaluating '$("select.ctools-master-dependent") .once('ctools-dependent')') `

I've tried changing Jquery Update settings, updating Panopoly to the newest version (along with the modules). No luck.

4
  • What's the error shown in JavaScript console of your browser? Hit F12 and reload page. Chrome can do it out of the box, Firefox requires Firebug, other browsers - can't tell.
    – Mołot
    Commented Aug 26, 2014 at 7:43
  • Hi Molot, it's what I pasted in my question (starts with "TypeError"). Commented Aug 26, 2014 at 7:45
  • Oh, sorry, failed to spot it. Are you using jQuery Update module? Is jQuery version set compatible with all modules' requirements?
    – Mołot
    Commented Aug 26, 2014 at 7:47
  • Yes I am. I've just updated the module itself, and the jQuery version is set to 1.7. (That's what works with Panopoly at least) I don't understand why it suddenly starts to happen - we finished the site in June and now our customer is suddenly having this problem. Commented Aug 26, 2014 at 7:50

1 Answer 1

0

I had a such problem with the module jquery_update when we used a library upper jQuery1.7 . Try use different jQuery versions for User interface and the Admin interface. And do not mix them.

4
  • Hi, My jQuery update (/config/development/jquery_update) configuration screen looks like this i.imgur.com/x3u6mkf.png shouldn't I be able to select different versions here? Commented Aug 26, 2014 at 10:01
  • I wanted to say that it is the main issue. It is the panels issue. Time to time I have a such issue. So I try to use the standard jQuery library and related old libraries. If I need new features. I inject a new library like jq17 making some hacks. Commented Aug 26, 2014 at 10:24
  • OK, I was just wondering how to use a different jQuery version for frontend/admin. Commented Aug 26, 2014 at 13:28
  • I fixed it by using a CDN inside jQuery settings. Thanks for the pointer. Probably something to do with caching of JS files or similar? Or wrong version perhaps? Commented Aug 26, 2014 at 13:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.