0

When I first made the front page, I created a Basic Page and selected "Promoted to Front Page" and thought I was done. Drupal insisted on showing this page as an article summary, and no manner of tweaking settings on my part prevented this behavior. I decided instead to put the main front page content in a block because it will seldom ever change.

I created my block, and yay! No more summarized front page content. However, the title of the page shows twice. The first is the title of the original basic page I created, the second is the title of the block I created. I've already cleared the cache and there was no change.

How do I get rid of the duplicate?

  • What does your page.tpl.php file look like? – beth Aug 27 '14 at 18:47
1

It sounds like you have node as your front page which lists summaries of content that is promoted to the front page by default. That's the way Drupal comes configured out of the box. If I understand correctly, what you're looking for though is a single node to be displayed in full on the front page.

You can change it from node (which shows a list) to your specific Node at admin/config/system/site-information or Configuration -> Site Information under the "Front Page" section. Simply change "node" to "node/[node-id]" where [node-id] = the nid of the node you want to appear on the front page:

Front Page Promotion

  • This the solution I was looking for in the first place before setting up a block. It's been ages since I've had to set up a Drupal website and I missed this. Thank you! :) – Heather M Aug 27 '14 at 19:20
1

I will address your situation by telling you both the solution to your previous problem, followed by your current conundrum.

The "promoted to front page" option is intended to be a list of several things (think of the front page of a blog). If you want a single front page, then change the settings for the front page (under admin/config/system/site-information). It is currently set to "node", which is a list of everything that is "promoted to the front page". Instead, change it to "node/#" (where "#" is the number of the node itself).

The other option is the way that you did it. It works, but as you see, it's a bit of a kludge. You can hide the title of the block by editing the block contents. There are 2 titles, so to speak. One is used for identification on the block administration page (the description), and one is for display (the title). Just leave the title blank.

0

Assuming you want to keep the block as your page content rather than setting a node to be displayed as the front page, there are a few ways to get rid of the title on the front page. Preferably using CSS since you don't have a H1 anywhere else on the page.

.front .page__title {
  display: none;
}

Or you could remove it completely by duplicating your themes page.tpl.php > removing the line that prints the page title > saving it to your templates folder as page--front.tpl.php

  • I didn't wish to keep the block, but did it because I didn't initially see the option to set a single node as the front page. Thanks anyway. :) – Heather M Aug 27 '14 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.