2

edit: it appears to be a bug, reported here https://www.drupal.org/node/2329723


When I, as the Admin, add a new user and let Drupal notify him via mail, the one-time login link is broken:

http://www.exmaple.com///www.exmaple.com/user/reset/...

Any idea why Drupal would create such a link? There is no module which alters this mail or tokens.

2
  • Where is Drupal installed, locally? Virtual hosts? Anythin with Apache conf that may meddle with this? Htaccess?
    – Wtower
    Aug 29, 2014 at 12:18
  • all other links look fine, its a live server. standard htaccess, standard apache conf (like our other websites have)
    – Alex
    Aug 29, 2014 at 12:20

2 Answers 2

2

There must be something, Drupal does not create broken links by default. Sadly, we can't debug your site for you. literally are not able to. See here - URL is accessible as [user:one-time-login-url] token, so if nothing overrides default support for this token, it must be OK.

Inspect http://example.com/admin/config/people/account, Password recovery tab. By default it should look like this:

[user:name],

A request to reset the password for your account has been made at [site:name].

You may now log in by clicking this link or copying and pasting it to your browser:

[user:one-time-login-url]

This link can only be used once to log in and will lead you to a page where you can set your password. It expires after one day and nothing will happen if it's not used.

-- [site:name] team

If this token is alone in it's line, just like above, then you know something interferes with tokens. If it's not, then maybe some automatic HTML syntax correction kicked in, and messed up your layout? It is impossible to tell without actually debugging your site.

5
  • i know that you cant debug my site :) i checked the mail text, its original, still so something is altering the token. i guess i will have to disable module by module, test and error.. :)
    – Alex
    Aug 29, 2014 at 12:19
  • @Alex Good luck. I'd really like to be able to tell you more, but sadly I'm not.
    – Mołot
    Aug 29, 2014 at 12:22
  • 1
    it is pathologic O.o now thats weird!
    – Alex
    Aug 29, 2014 at 12:28
  • @Alex weird indeed. Glad you figured it out but... sorry, have no idea what to do next.
    – Mołot
    Aug 29, 2014 at 12:36
  • 1
    thats okay, i reported a bug drupal.org/node/2329723
    – Alex
    Aug 29, 2014 at 12:37
2

Its a long time since this question has been posed; but I faced the same problem yesterday, and searched for a solution on the net. There are a lot of technical details floating about, and the original poster has referenced the issue on the drupal.org site; though the remedies pertain to Drupal 6.

The solution for Drupal 7 is as follows:

goto administration >> configuration >> content authoring >> text formats

In 'text formats' there are editable options for 'full html', 'plain text', and 'filtered html'. Clicking on each, at the bottom, there's the sub-section 'Filter Settings' and over here you can change the 'Maximum link text length' from its default value of 72 char to anything you fancy 147, 255, 257, etc.

On my site, this resulted in a successful use of the one-time login link which was full and unbroken.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.