2

I am having a strange problem with my drupal website where site is working and anybody is able to surf it properly however the moment I try to login using my admin or account it shows offline message given below. What could be the reason

+++++++++++++ Site off-line

The site is currently not available due to technical problems. Please try again later. Thank you for your understanding.

If you are the maintainer of this site, please check your database settings in the settings.php file and ensure that your hosting provider's database server is running. For more help, see the handbook, or contact your hosting provider.

  • 2
    Even if site is offline you can able to login by navigating to /user/login page... – Anil Sagar Sep 1 '14 at 5:46
  • site is working fine and I am able to go to user/login page but the moment I login sites shows offline page – Devang Sep 1 '14 at 6:33
  • Did you manage to resolve the issue? If yes, then how? – consuela Jun 18 '15 at 0:31
0

Currently your site in maintenance mode. You need to login as admin and put your site in online mode.

Step 1: Login as admin www.example.com/user

Step 2: Change the site status as online www.example.com/admin/settings/site-maintenance

  • 2
    no it is not that. Site is not in maintenance mode and perfectly running. However I cant login as admin also as I am not getting inside and just seeing site offline window – Devang Sep 1 '14 at 6:20
0

As you can not login from in your site the only way to do something is from database end, if you have access to database try doing this to come out of this mess up:

Try to empty the sessions and the cache tables. Not DELETE! Empty them. then see if you can login from http://www.yoursite.com/?q=user

Or look if your site is in maintenance mode if it is the follow instructions given here: https://www.drupal.org/node/276457

Hope above will work for you and you will get your site back to normal. Good luck!

  • Hi emptied sessions and cache but problem remains. I just see a page with offline message and not able to get inside the admin module. Otherwise website is running fine. – Devang Sep 3 '14 at 5:38
  • It seems that some connection problem with database look here if it work for you: drupal.stackexchange.com/questions/24145/… – Ashish Bairagi Sep 3 '14 at 6:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.