2

Drupal 7, commerce shipping 2.0, and usps shipping method. Configured the product types with weight and dimension physical field. All products have weights and dimensions. All USPS services checked. The username and the connection address are set. The shipping service pane is in the correct sequence in checkout (after shipping info). At shipping services during checkout I get "No shipping rates found for your order. Please continue the checkout process."

1

I had added the weight and dimension fields to the existing products using defaults. I needed to save each product for these to take effect. Works now.

| improve this answer | |
0

Seems like you got USPS Shipping to work in Drupal Commerce. I have also been trying to get this thing to work, but without much success. I also added the weights and dimensions as defaults. Then, upon seeing your post, saved them all again. I stil get the "No shipping rates found for your order. Please continue the checkout process." message.

Can you please guide me with step-by-step instructions for the whole process? I will be very grateful.

Thanks in advance, Jasper

| improve this answer | |
  • Check if USPS production url and USPS API username is correct. Username must be activated to use the production url. – Tejas Vaidya Aug 16 '16 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.