0

I have an RSS feed going into mailchimp for my website (www.abercynonprimary.org.uk), feeding off the News page which is a View of teasers. The feed address is the website address with "/news.xml" on the end.

The problem I have is that mailchimp needs the tag :

<content:encoded> 

somewhere in the feed, in order for me to properly use the mailchimp rss tag of full_content. At the moment, as mailchimp cant see the content:encoded html tag in my feed, it treats it as summary content, and generates a Read More in my Newsletter which doesnt work (links to nothing).

I'm just using the Views setting of Content (not fields) in my News View for the feed (see screen shot attached). I have also attached the note back from Mailchimp Support.

Mailchimp Support - *"I checked the feed for the your account and it appears that there's "content:encoded" within the feed, but it is not explicitly spelled out in the tags as

<content:encoded>

In order for MailChimp to read this as expected, this tag needs to display exactly as stated in the Merge Tags article on the feed. Once these tags are added, things should work as expected and you would only need the default "read more" link that comes with the Merge tag. "*

can anyone help me get my feed to show full content instead of defaulting to summary, and therefore causing Mailchimp to generate a Read More which doesnt work.

thanksenter image description here

1 Answer 1

1

You can use Views RSS: Content Elements module, I'm using it and works well...

9
  • i have installed the module on my pc version, do i need to configure anything? How can I tell its now generating the html tag? thanks. Sep 5, 2014 at 15:22
  • no configuration needed, just enable module...
    – mixerowsky
    Sep 5, 2014 at 15:31
  • will do, but how can I check the element is being populated in the feed ? really appreciate your help with this . Sep 5, 2014 at 15:57
  • in browser go to address view-source:www.abercynonprimary.org.uk/news.xml or whatever url for your feed is...of course, don't forget to run cron/clear cache after module enabling...xml code of your feed will be shown, just look for <content:encoded>, if it is there that is it...
    – mixerowsky
    Sep 5, 2014 at 16:06
  • i get this in the Description element whether the module is installed or not : property=&quot;content:encoded&quot;&gt;&lt;p&gt , but alas, not a proper html element for <content:encoded> with the module enabled. I cleared cache and run cron also, checked in firefox using view-source, used firebug too. Sep 5, 2014 at 16:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.