0

I am new to Drupal. After reading about it and watching some tutorials, I tried to install Drupal 7 on my localhost to see it for myself. But now it is installed, I see no admin toolbar on top of the page. On the place where the toolbar should be I get the following code: $S$DWqdyauf.rdiK9FyIjcO5oZuwyz2HaRQiTO2Ot/5o4YIN8fxcH3u

In the middle of the page it does say 'add more content', so I guess I do have an admin account.

I tried to change the rights via PHPadmin, but sometimes I ended up having no access to the page at all anymore. When I refresh the page I get a different code. It happens in both Chrome and Explore.

What can I do to see a toolbar?

Thank you for your time. Mariska.

An example

  • 1
    Cache clear, update.php, login and logout didn't help? Un-checked JS and CSS aggregation? – Mołot Sep 7 '14 at 20:24
  • 1
    I cleared my chache but that didn't help. When I logout it says 'access denied', so I cannot login anymore. I did manage to get the login page a few times, but then I don't see a toolbar either. And I only tried to install drupal, I didn't do anything else, so I cannot have made a mistake with JS or CSS yet. I must have done something wrong during the intallation, but I have no idea what or how to repair it. – user3168600 Sep 7 '14 at 21:39
  • what version of php is running? – Geoff Sep 7 '14 at 22:04
1

Sounds like an incomplete or partially failed install. Delete all the tables in the database and try doing a fresh install.

Try performing the install with Drush so you can see in real time if there are any errors when writing to the database (look under "Quick installation with Drush"): https://www.drupal.org/documentation/install/developers

Also make sure you're running PHP 5.3+ and MySQL 5.0.15 or higher with PDO: https://www.drupal.org/requirements

  • I deleted drupal and tried again following another tutorial and now I do see the toolbar. I also had both xampp and wampp installed. I deleted xampp, maybe there was a conflict? However, my problem is solved. Thanks for commending. – user3168600 Sep 12 '14 at 10:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.