1

I have this drupal 7 site. I wanted to clone it in order to try some new stuff in it, without working on my localhost. So I did it, following these steps:

Cloned the database:

mysqldump -h localhost -u XX -p XXX > backup.sql
mysql -h localhost -u newXX -p newXX < backup.sql

And then cloned the files and changed their perms:

rsync -avHl /home/XX/public_html/* /home/newXX/public_html
chown -R newXX. /home/newXX/public_html/*

After that I've updated and changed the settings file (to use in the cloned files the new database credentials), and created a new .htmlaccess file.

All went well and good. The new site was just like the older site, and both sites were running ok.

A few days have passed since then.

But after that the old site have all WSOD inside every page, except the frontpage.

It was a cache problem, that didn't solved clearing all cache tables, but adding this into my settings file:

$conf = array(
'cache' => '0',
'preprocess_css' => '0',
'preprocess_js' => '0',
'block_cache' => '0',
'page_compression' => '0',
);

The thing is that I can't have my site without caching, and even after successfully logging in and manually unchecked all cache items under admin/config/development/performance, I get the WSOD if I try and remove the $conf array I've manually set at the settings.php file.

Note: I have memcached installed on my server, and this is what I've added in my settings.php file:

$conf['cache_backends'][] = 'sites/all/modules/memcache/memcache.inc';
$conf['cache_default_class'] = 'MemCacheDrupal';
$conf['memcache_key_prefix'] = 'memcache_liga';
$conf['cache_class_cache_form'] = 'DrupalDatabaseCache';

Please note that I've uninstalled memcache module on the cloned site, and deleted that configuration inside the settings file of the cloned site.

Why is all this happening? And what I may do about this?

Update: I forgot to mention that I've added to my index.php right after the opening php tag, this:

error_reporting(E_ALL);
ini_set('display_errors', TRUE);
ini_set('display_startup_errors', TRUE);

And when the error appears (WSOD), the page is still completely blank!

  • Having memcached installed on your server does make drupal use it. Do you have the memcache drupal module and is it properly installed (it might include some configuration in the settings.php) ? – DuaelFr Sep 9 '14 at 0:00
  • Thanks for your comment! I've updated the question with the memcache settings in settings.php – Rosamunda Sep 9 '14 at 0:30
  • Ok now you might follow these instructions to make to error appear on the WSOD then paste it here. – DuaelFr Sep 9 '14 at 0:33
  • I forgot to mention that I already done that (right after the opening php tag), and it still shows it completely blank. – Rosamunda Sep 9 '14 at 1:03
  • Depending on your server setup I would not rely on ini_set() unless you can confirm that you are able to override PHP configuration via that method. I would check the actual error log. – rooby Sep 9 '14 at 1:21
1

Here is how I do in my local projects, may be it can help you.

I have one main project(local) and four its instances(cloned). Same files, same db structure (I'm using Memcache Storage module).. First time when I've tried to clone and work on them I faced some strange problems, then I found that they were sharing cached data (I was using default memcached instance with 11211 port).. Then I just copied the default memcached.conf file as memcached_1.conf(memcached_2.conf,...) and changed their port as 11212,... in them, restarted all memcached instanes(sudo service memcached restart), and specified those ports to to my cloned projects in their settings.php, that solved my problem..

2

Are you sure the two instances don't somehow share the same memcached server with the same prefix? That's when these things happen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.