0

Lately I was trying to install drush for the first time. This is what I did..

  • Installed the drush tool manually
  • Extracted and renamed the tool to /Library/Drush
  • Gave the /Library/Drush/drush tool execution permissions.
  • Created an alias for drush in ~/.bashrc
  • Tried to bash drush by entering the alias drush, that's when I got the first problem: Unable to load autoload.php. Drush now requires Composer in order to install its dependencies and autoload classes. Please see README.md
  • After lots of searching I tried way to many things:
    • which drush doesn't return anything.
    • Installing the composer (at /usr/local/bin/composer) results in this The requested package drush/drush 1.0.0 could not be found problem when executing composer global require drush/drush:dev-master

Help would be appreciated, because I don't know what I could do to make it work.

Thank you in advance, `F.

  • 1
    If you're struggling to do it manually, why not just use Homebrew? brew install drush is all you need – Clive Sep 16 '14 at 14:28
  • @Clive This did the trick, thought I tried this already. Anyway thanks! – Fleuv Sep 16 '14 at 14:59
1

I have encountered the same error while installing the drush on MAC, I have tried the following and that worked for me:

composer self-update
ln -s /path/to/drush/drush /usr/bin/drush

I have downloaded the Drush from this git repository: https://github.com/drush-ops/drush

And followed the method described here for installing the Drush on MAC: https://www.drupal.org/node/1674222


For Installing Drush on Mac using Homebrew, check https://www.drupal.org/node/954766

  • This didn't work for me neither, still got the same error. But I didn't used the drush download you use (drush-master). The additional solution @Clive commented did work! – Fleuv Sep 16 '14 at 14:58
  • @Fleuv Yes for MAC using Homebrew is a good option, anyways I have also mentioned this as well as a alternate option :) – Ankit Agrawal Sep 16 '14 at 15:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.