I've installed workbench and tried to work with it. I followed the step-by-step instructions given in the video here and I was almost successful in creating the content and moderating it between the two kinds of user one is Publisher and the other is content-creator.

Content-creator creates the content and forwards it to needs-review, now the publishers gets the access to the content in the needs-review tab. And the moderation should be done between these two users.

Here, my issue is when the content-creator creates a content - he is unable to see his content in his profile (I mean either in 'MyContent', 'MyDrafts' and 'Needs review'). And the same case with the other user (publisher)- the Needs-review tab looks empty even though there is some content created by 'content-creator'.

To keep it short, MyWorkbench tab looks empty- the Needs-review tab, MyContent tab and MyDrafts tab are empty. The only way the content appears is in Content tab.

I'm not aware of workbench module, I've followed all the instructions given in the video. I'm missing any?? Please give your answers.

Thanks in advance.

  • Have you checked the permissions carefully?, once again verify the permissions as mentioned in the video and that should work. Sep 16, 2014 at 21:04
  • In the workbench access settings, it says the content type does not have any fields that can be used for access control.
    – GIRI
    Sep 17, 2014 at 22:10
  • What does that mean?? @AnkitAgrawal
    – GIRI
    Sep 17, 2014 at 22:11

4 Answers 4


Check your permissions in the Admin area for Workbench for each Role at admin/config/workbench/moderation/check-permissions

This is a module that has been at 1.0 for a very long time and is mature.

  • need to clear the cache. now its working.
    – GIRI
    Oct 6, 2014 at 1:35

I faced the same issue where 'Needs Review' tab appeared empty after the workbench moderation state for conten type is set to 'Needs Review' or 'Draft'by the creator. I applied a patch from drupal.org and it worked. Please find the below patch and apply it in your Workbench Moderation module.


Let me know if you still face an issue.


Have you modified the default View that Workbench Moderation creates? Make sure that no changes have been made that may alter what is displayed in the various Workbench tabs.


Home > Administration> Configuration > Workbench > Workbench Access

Select Require a Workbench Access Form Elemententer image description here

I was using Drupal 7.34 , I also followed the same tutorial link The tutorial link

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.