0

I set this tick box in the performance area, and on clicking Save I now cannot access the site, even the performance area to disable this! any one know if I can directly change this in the DatabasE?

EDIT: I have refreshed the Database, thankfully no updates since it went live. This does raise the question though as I'm not the only one who has had problems with these performance tick boxes, how do you back out of an error?

I would still like the answer cause i'm trying to get to the bottom of these performance settings.

thanks for any replies.

4

I found this from http://drupal.org/node/782510

In your settings.php file, add

$conf['preprocess_css'] = CACHE_DISABLED;

Seemed to work for me on a quick test

  • thanks. I have such a hard time finding anything of use in the Drupal forums/posts, so I spend most of my time here. now off to find out why these settings keep breaking my sites! – Purplemonkey Oct 12 '11 at 10:26
1

If you're looking for a good alternative for core's preprocessing of CSS/JS check out the Advanced CSS/JS Aggregation module

0

I believe this setting is stored in the variable table as preprocess_css

UPDATE variable
SET value = 'i:0;'
WHERE name = 'preprocess_css'

and then clearing cache should do the trick. I am also pretty certain just deleting that row should do the same thing, as the default value is 0, and variables not in the table take on their default value via variable_get().

I should add, that if you can't clear the caches from the site itself, nor via drush, you can go in any manually clear out these tables.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.