0

I'm having issues getting the drush sql-sync command working, and it seems to be related to how my site aliases are set up. When I try to run the sql-sync command with my local and production aliases, I get the following vague message:

The command could not be executed successfully (returned: The system cannot find the path specified., code: 1) [error]

It doesn't get much more specific than that even when running with -v or -d flags. I get the same error when I run drush sa --with-db @erg_d7.local, as suggested in this post. There's obviously an issue with the database information, but I'm not sure how to fix it given that error message.

The alias file I'm using includes the following local alias:

$aliases['local'] = array(
  'root' => 'c:/wamp/www/erg_d7',
  'uri' => 'erg.local',
  'target-command-specific' => array(
    'sql-sync' => array(
      'create-db' => TRUE,
      'mode' => 'rultvz'
    )
  ),
  'path-aliases' => array(
    '%dump' => 'db/db.sql',
    '%files' => 'sites/default/files',
    '%code' => 'sites/all'
  )
);

I'm wondering if this is an issue with how the paths are written out (given that I'm using Windows 7), but I've tried formatting with backslashes as well as writing out absolute paths for the path-aliases, including leading slashes, etc.

2

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.